1

It might be a very naive question but I've not managed to solve it on my own and failed to find any solution online (I'm probably missing a keyword or two to get helpful search results)

I am using BunsenLabs which uses Openbox as its graphical environment.

I've set in Xfce Power Manager that my screen can go blank after 10 minutes if there is no action for a user. The screen goes black after 10 minutes as expected but it happens that when I move my mouse it asks me to log in.

I doesn't ask me to log in immediately after the screen goes blank however.

I wonder how I can turn off the log out feature. I want to disable lock screen when screensaver is active feature.

Notes:

  • Here is a screenshot from Ubuntu (from a useful Ubuntu thread):

    enter image description here

    I'd like to be able to turn the screen off after 10 minutes and don't require the password after waking up from suspend. If I decide to lock my screen manually however, I'd like it to prompt me for the password.

  • Another useful thread: Disable automatic screen lock in XFCE in Centos. None of the solutions worked for me however.

  • Adding xset s off & line to my ~/config/openbox/autostart and restarting Openbox didn't work. xset -dpms s off is not helping as well.

  • 1
    I am not familiar with Openbox but in general, the password prompt you see when you come back is not a login prompt. It is for unlocking a screen lock more than likely. You may disable this screen lock. According to a suggestion I found in THIS PAGE page, you can Add "xset -dpms s off" to your .xinitrc or your openbox autostart script? – MelBurslan Mar 31 '16 at 22:12
  • @MelBurslan Right! It might be true. I forgot about it. Let me try it out. – Mateusz Piotrowski Mar 31 '16 at 22:12
  • @MelBurslan. Update. It doesn't work – Mateusz Piotrowski Mar 31 '16 at 23:28
  • in the GUI you posted the picture of, try the pull down Lock Screen After and set it to a very high number of minutes, instead of "screen turns off" selection. When you hit tht number of minutes, it will lock it and ask you for password but you want that anyway. If you are not around for 3 hours, it means you are gone for a good while and locking the screen is for your benefit – MelBurslan Apr 1 '16 at 4:51
  • @MelBurslan Sorry if my post is not clear. I'd like the screen to go blank without the sceen-lock feature. The GUI I've posted is from Ubuntu. There's no such GUI in BunsenLabs; at least not in the standard set of utilities. – Mateusz Piotrowski Apr 1 '16 at 5:43
1

I am not familiar with Openbox but in general, the password prompt you see when you come back is not a login prompt. It is for unlocking a screen lock more than likely. You may disable this screen lock. According to a suggestion I found in THIS PAGE, you can Add "xset -dpms s off" to your .xinitrc or your openbox autostart script?

EDIT : Providing this as an answer so that it can be marked as solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.