2

I have two folders called Documents and Downloads. In zsh, when I type

cdSpaceDoTabc

the color of Documents change from white to (hard to read) gray. How can I turn off this color change or control the color it is changed to?

Here's my .zshrc

The problem lies in this line here, where I change the coloring:

PS1="%F{$colorUser}%n%{$reset_color%}@%F{$colorServer}%m %{$reset_color%}: %F{$colorPath}%~%{$reset_color%} $ "

The variables are simply numbers, e.g. $colorUser=196, $colorServer=202, $colorPath=44.\

  • Paste your .zshrc... – jasonwryan Mar 31 '16 at 20:26
  • @jasonwryan Edited my question. – pfnuesel Mar 31 '16 at 20:29
  • Ugh: OMZ. Sorry, can't help with that ratmangle... – jasonwryan Mar 31 '16 at 20:36
  • @jasonwryan What do you mean by ratmangle? It's mostly a fresh install from oh-my-zsh. – pfnuesel Mar 31 '16 at 20:40
  • 1
    I mean OMZ is a ratmangle. Does the behaviour persist if you disable it? I certainly can't reproduce on my Zsh. – jasonwryan Mar 31 '16 at 21:06
0

Instead of using e.g. %F{202}, I can use %{$fg[red]%}. This fixes the problem. However, I'm reduced to only use 16 colors instead of 256 colors. It seems to me like this is a bug in zsh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.