3

I watched my laptop reboot after a system update and there was an error mention that caught my attention. I issued a # dmesg | grep radeon and the results were:

[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.10.0-327.10.1.el7.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet LANG=en_US.UTF-8 radeon.modeset=0 rd.driver.blacklist=radeon
[    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-327.10.1.el7.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet LANG=en_US.UTF-8 radeon.modeset=0 rd.driver.blacklist=radeon
[    3.837187] [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!

I understand UMS is deprecated, and I don't really need very powerful video performance on this laptop, but it would be nice to have nicer font rendering.

# lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Chelsea LP [Radeon HD 7730M]
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
08:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

How to solve it?

  • may be it got enabled while doing the update, If you want to disable it, try adding the parameter radeon.dpm=0 to the kernel parameters as suggested [here] (wiki.archlinux.org/index.php/ATI) – Corleone Mar 31 '16 at 19:39
2

I had a similar issue, in my case the reason was the nomodeset kernel parameter passed by GRUB2. I just removed it from the GRUB2 config and everything works well since then. I suppose that in your case, by analogy, the problem is with radeon.modeset=0 rd.driver.blacklist=radeon at the end of your kernel command line. Depending on how well you feel with GRUB configuration you can try to fix it manually or use GRUB Customizer (I went with the second option). Find the kernel command line and change it from
BOOT_IMAGE=/vmlinuz-3.10.0-327.10.1.el7.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet LANG=en_US.UTF-8 radeon.modeset=0 rd.driver.blacklist=radeon
to
BOOT_IMAGE=/vmlinuz-3.10.0-327.10.1.el7.x86_64 root=/dev/mapper/centos-root ro crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet LANG=en_US.UTF-8 radeon.modeset=1
or delete the "radeon.modeset=0 rd.driver.blacklist=radeon` part entirely.

  • where is this file to edit? how do I set the Boot_image? – sojim2 Mar 24 at 23:26
  • @sojim2 as I've written in my answer, you can use GRUB Customizer (it's a utility program) and guessing that you're not an expert, I recommend that as the first choice. – Krzysiek Setlak Mar 26 at 21:57
  • Choose the entry you want to edit and look for the part where arguments passed to the kernel upon boot are located. The line will look something like this: linux /boot/vmlinuz-5.0.3-200.fc29.x86_64 root=UUID=991a20b8-a4be-4f84-ae9e-fbdb884e773c ro rhgb quiet (you can navigate by searching for ro rhgb, these arguments will most likely be there) and if you find radeon.modeset=0 there, just change it to radeon.modeset=1 and remove rd.driver.blacklist=radeon. – Krzysiek Setlak Mar 26 at 21:57
  • The second option is editing the GRUB config file that is likely located in /etc/default/grub in case of CentOS. Edit the GRUB_CMDLINE_LINUX line just like you would according to the instructions given above and then follow the instructions given here: wiki.centos.org/HowTos/Grub2 to "save" the changes (generate the actual config). – Krzysiek Setlak Mar 26 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.