3

I have a laptop running Arch Linux. At home, I can connect to my OpenVPN server without problems; however, my college network seems to use some odd configuration where upon connection I'm assigned two IP addresses by DHCP.

ip addr:

2: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 18:5e:0f:90:55:29 brd ff:ff:ff:ff:ff:ff
    inet xx.xx.127.167/24 brd xx.xx.127.255 scope global wlp3s0
       valid_lft forever preferred_lft forever
    inet xx.xx.127.227/24 brd xx.xx.127.255 scope global secondary wlp3s0
       valid_lft forever preferred_lft forever
    inet6 xx::xx:xx:fe90:5529/64 scope link 
       valid_lft forever preferred_lft forever

I have hidden the addresses because there's no NAT, so those are my actual public IPs.

When I connect to OpenVPN, I'm unable to send any traffic anywhere; even the local IP of the VPN gateway in the LAN, let alone any outside hosts. I suspect the dual IP configuration is responsible for this, because judging from ip route there's no route added for packets originating at that IP:

0.0.0.0/1 via 10.8.0.5 dev tun0 
default via xx.xx.127.254 dev wlp3s0  src xx.xx.127.227  metric 302 
10.8.0.1 via 10.8.0.5 dev tun0 
10.8.0.5 dev tun0  proto kernel  scope link  src 10.8.0.6 
<vps ip> via xx.xx.127.254 dev wlp3s0 
128.0.0.0/1 via 10.8.0.5 dev tun0 
xx.xx.127.0/24 dev wlp3s0  proto kernel  scope link  src xx.xx.127.227  metric 302 

The default entry restricts the source address to what is listed above as the "secondary address"; I suspect this is what causes the packets not to be sent anywhere. Oddly enough, even if I configure the connection manually, I will still be assigned another, "secondary" IP (I'm using NetworkManager).

I tried addding another route for the .167 address, but to no avail; nothing changes. I should add that the network definitely doesn't block VPN traffic because I can use it on Windows 8 (dual boot on the same laptop) and on my Android phone without problems (same server). Also, there are no warnings or errors displayed during the OpenVPN connection sequence.

Am I correct in my suspicions that this dual IP configuraiton is causing VPN problems?

  • 1. If you still get two IP addresses when you manually configure the connection, what makes you think it's the DHCP server? Seems more likely to be something in your network configuration. 2. does your laptop get two IP addresses when you boot into Windows? – cas Mar 31 '16 at 21:26
  • @cas No, everything's fine on Windows. Additionally, I've noticed that initially I only get one IP; it is only after I connect to the VPN server (and later terminate that connection) that ipaddr shows two IP addresses assigned to the WiFi card. – szczurcio Apr 4 '16 at 12:12
  • that seems to disprove your theory that it's DHCP assigning two IP addresses....and also points the finger at your VPN setup. – cas Apr 4 '16 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.