0

I am trying to install Drupal 8.0.5 on Apache 2.4.6 on CentOS 7, with PHP 5.6.19. I get an error that PHP extensions are disabled. The detail I get is that it pertains to "gd."

I have installed, with yum install these packages: gd, gd-devel, php-gd, php-pdo php-mbstring, php-xml.

I have installed various other packages. I have no reason to think that PHP gd extensions have not been enabled. They've certainly been installed. I've restarted Apache services and MariaDB services. I've rebooted the sever.

I reinstalled Drupal and PHP. I created a php.ini file with "extension=gd.so" as the content.

What should I do to get Drupal working for the first time? I have never done this before. How do I enable the PHP Extensions? Or is the message false? If it is, what should I do?

Main problem (circular dependencies that can never be fulfilled): To ensure that I have the correct versions of the packages, I tried to install php56-php-common-5.6.19-2.fc24.remi.x86_64.rpm. But I get an error that it requires php56-php-pecl-jsonc(x86-64). To handle this requirement, I tried to install this package. I then tried to install php56-php-pecl-jsonc-1.3.9-1.el7.remi.x86_64.rpm. But I got an error that I needed php56-php(zend-abi). This package seems to be the php56-php-common one above. When I search for php56-php(zend-abi), I get brought to this URL: https://www.rpmfind.net/linux/rpm2html/search.php?query=php56-php%28zend-abi%29

What should I do?

0

All this package comes from this SCL: https://www.softwarecollections.org/en/scls/rhscl/rh-php56/ You need to enable this repo. Then you need to operate with SCL similarly as this tutorial http://developers.redhat.com/blog/2013/08/01/php-5-4-on-rhel-6-using-rhscl/ (just replace php54 with php56).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.