3

I am trying to install Arch Linux on a brand new Lenovo ThinkPad X1 Carbon 4th. When I start from my LiveUSB image, it gets stuck right after the following line (which is the first line of the screen):

Probing EDD (edd=off to disable)... ok

I created my LiveUSB stick from OSX with dd like in the documentation from Arch Linux (here)

It seems like the "Probing EDD" is not the problem, since it says "ok". How can I know what the problem is?

2

I had to add intel_pstate=no_hwp to the kernel parameters. I did it by pressing [Tab] in the bootloader.

I found the solution here.

1
  • This doesn't work with me. Windows 10.0.19042, Virtual Box 6.1.18, archlinux 2021-03-01. Mar 4 at 9:51
1

That is one way but what I did was:

  1. Click settings before starting the VM
  2. Goto to System
  3. Look at Extended Features
  4. Click "Enable I/O APIC"

Note: This only works for a VM sorry

It solves it but I don't know what the effects are.

2
  • This is only for a VM
    – Liam Jones
    Nov 29 '16 at 2:09
  • This doesn't work with me. Windows 10.0.19042, Virtual Box 6.1.18, archlinux 2021-03-01. The I/IO APIC feature is switched on by default if you add multiple virtual cores. Mar 4 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.