1

EDIT: not sure if I can delete this? Everything corrected itself once I turned the other pc off. Seems interference was happening across certain wires. (Still wouldn't mind knowing what the solution would have been, though)

The situation:

  1. A pre-built Asus vivo (i5 version), also pre-owned
  2. A sharp 1080p@60hz 46 inch television (unknown model, cannot recognise it in a google image search)
  3. A fresh install of the latest debian, with lxde and lightdm as my preferred managers.

The problem: Whenever the display tries to use the native resolution, it either fails to display entirely (the tv says incompatible video signal) or it shows a corrupted screen that I can only partially operate in (sometimes randomly blanking out to the bad signal indicator). It seems more inclined to show a corrupted screen after I've logged in, which means I have to login blind (perfectly feasable).

It tries to use this native resolution from when xwindows starts, I believe.

I suspect three possible things: the tv is not supplying correct EDID information (a dump of an app I've now forgotten the name of showed some garbage in the EDID the display was giving), the hdmi cable is faulty (it's the only one I currently have) or the pre-owned machine I got from amazon marketplace was faulty, which might be why it was returned to begin with.

Anyway, during one of the windows of opportunity where I could actually see the screen, I added the following line to my lxsession configuration under 'autostart': xrandr --auto --output HDMI1 --primary --mode 1920x1080i --rate 60

The interlaced version is functional (albeit the screen shimmers when I move windows around). So now once I login, I can get a normal-looking screen. (If I switch to one of the other terminals with ctrl+alt+F1 it goes back to saying incompatible signal)

My goal is to either have the interlace be the default display mode for the entire boot process post-grub, or better still, to add a corrective mode (assuming bad edid) that allows me to see the native display resolution properly, but I am intimidated by making new entries to xorg.conf and without knowing the model of my display, I don't know what values to put in (plus it seems that xorg configuration can be placed in multiple places and I don't know what overrides what--it would be quite annoying if I found my changes not working only to find out that the configuration wasn't being applied at all). Although the display does show properly on windows, so maybe I could find the values in windows somewhere?

Instead of editing xorg.conf, and out of ignorance of exactly in what order the boot process occurs, I tried cutting and pasting that xrandr line that puts it in interlaced mode, in as many startup places as possible. Didn't work. I also lost track of where exactly I made edits (tried doing a grep of the entire harddrive and sorting by date to figure out what I changed but it was taking way too long).

I do know from booting into recovery mode and starting a session that the HDMI1 device doesn't exist during that time, so maybe it doesn't exist at those points during the boot process that I inserted them, either. I wouldn't mind knowing when those get added.

In any case, I could do with someone holding my hand through this problem.

0

This sounds a driver issue, you can download the installer from here https://01.org/linuxgraphics/downloads/intel-graphics-installer-linux-1.4.0

The Ubuntu ones should work in debian, if the problem persist, the newest versions of the kernel have lots of improvements for intel devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.