0

I'm trying to install some packages on my server (Debian8) and for some of they, I always have dependencies problems.

For example, I have executed this command:

apt-get install jetty9

And It answer that I've asked impossible things and say that the dependency libjetty9-extra-java is not satisfied . I can't understand why.

Can someone tell me why I get such errors?

Here is the error :

Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable                                                                                             
distribution that some required packages have not yet been created                                                                                             
or been moved out of Incoming.                                                                                                                                 
The following information may help to resolve the situation:                                                                                                   

The following packages have unmet dependencies:                                                                                                                
 jetty9 : Depends: libjetty9-extra-java (>= 9.2.14-1~bpo8+1) but it is not going to be installed                                                               
E: Unable to correct problems, you have held broken packages.

And this is my sources.list :

#de://debian.mirrors.ovh.neb httpt/debian/ jessie main                                                                                                         
#deb-src http://debian.mirrors.ovh.net/debian/ jessie main                                                                                                     

deb http://security.debian.org/ jessie/updates main                                                                                                            
deb-src http://security.debian.org/ jessie/updates main                                                                                                        

# jessie-updates, previously known as 'volatile'                                                                                                               
deb http://debian.mirrors.ovh.net/debian/ jessie-updates main                                                                                                  
deb-src http://debian.mirrors.ovh.net/debian/ jessie-updates main                                                                                              

# jessie-backports, previously on backports.debian.org                                                                                                         
deb http://debian.mirrors.ovh.net/debian/ jessie-backports main                                                                                                
deb-src http://debian.mirrors.ovh.net/debian/ jessie-backports main                                                                                            

deb http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free                                                                                         
deb-src http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free
9
  • Please include the full error text, the version of your distribution, and possibly the contents of /etc/apt/sources.list in your question. Unsatisfiable dependencies often occur because of conflicting distribution versions.
    – Celada
    Commented Mar 28, 2016 at 12:42
  • @Celada Here is the content of my sources.list pastebin.com/mtnTSPzd I have Debian8. The error test is in French...
    – Laurent-P
    Commented Mar 28, 2016 at 12:57
  • Please edit your question so it contains all of the information that is relevent. We're not going to go to all kinds of external sources to find the bits and pieces of your problem. Also, le message d'erreur complet, s.v.p.
    – Celada
    Commented Mar 28, 2016 at 13:00
  • 1
    Better having them in French than not having them. LANG=C apt-get install jetty9 also should produce errors in english. Commented Mar 28, 2016 at 13:00
  • I've added the content you asked. Sorry for wasting your time :(.
    – Laurent-P
    Commented Mar 28, 2016 at 13:06

3 Answers 3

6

Your jetty9 package is using the backports, as it can be seen by the bpo8 string.

As you already have jessie-backports configured in sources.list, do:

sudo apt-get update
sudo apt-get -t jessie-backports jetty9

The -t jessie backports is a hint to apt for using the jessie-backports repository.

Also check:

https://packages.debian.org/jessie-backports/jetty9

backports.debian.org "Backports are packages taken from the next Debian release (called "testing"), adjusted and recompiled for usage on Debian stable. Because the package is also present in the next Debian release, you can easily upgrade your stable+backports system once the next Debian release comes out."

2
sudo apt-get clean

followed by

sudo apt-get -f install
2

Just a typo in your second command :

sudo apt-get -t jessie-backports install jetty9

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .