3

I am new to linux and decided to go with Fedora 23 on my new laptop, a Thinkpad T460s.

I installed Fedora 23 and the wireless has been disappointing so far. My kernel version is 4.4.6-300.fc23.x86_64.

I ran SpeedTest.net on my rMBP and my Thinkpad.

On my rMBP I got 12.2 Mbps down and on my Thinkpad I got 0.91 Mbps down from the same location.

The Thinkpad is showing ~50-60% wireless connectivity.

I know this is a general question, but I honestly have no idea where to start on how to debug this. Should I start poking around the RedHat bug reports? Are there linux commands that will help me debug this?

EDIT: Here is the output of lspci -nnk | grep -iA2 net:

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet
Connection I219-V [8086:1570] (rev 21)
    Subsystem: Lenovo Device [17aa:2233]
    Kernel driver in use: e1000e
--
04:00.0 Network controller [0280]: Intel Corporation Wireless 8260
[8086:24f3] (rev 3a)
    Subsystem: Intel Corporation Device [8086:0130]
    Kernel driver in use: iwlwifi 
  • What wireless card? Please edit the question to include lspci -nnk | grep -iA2 net – Jeremy31 Mar 27 '16 at 21:57
  • Might it be a hardware problem? Can you dual boot into Windows and compare? Do you see the same slow speed when connecting by ethernet? – Sparhawk Mar 28 '16 at 0:48
  • Could be. I installed Fedora 23 as my main workstation and got rid of windows so I would have to create a partition and install. I'll try ethernet right now. – Adam Thompson Mar 28 '16 at 0:49
  • @Sparhawk very fast on ethernet. Also shows 100% connectivity. – Adam Thompson Mar 28 '16 at 0:51
  • Okay. Obviously, it could still be the wifi hardware. I'm not sure how Windows works, but can you boot into a "live DVD" and not bother installing/partitioning? You could also use an Arch Linux, Ubuntu, etc. live DVD, and test their wifi drivers. However, if you see similar slow speeds, it wouldn't be very informative (i.e. could still be Linux or hardware). – Sparhawk Mar 28 '16 at 0:55
2

An old bug report indicates that a performance gain can be achieved using

echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwl11n.conf

Reboot

This option actually doesn't disable anything but enables aggressive TX

Also check the encryption of the wireless access point

iwlist scan | egrep -i 'ssid|cipher'

You want to see this below your access points ESSID

                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
If you see TKIP, it will cause problems. Most routers will have a encryption setting to disable TKIP usually called WPA2-AES, WPA2 only, or WPA2-PSK

  • Thanks Jeremy. It feels a bit faster but unfortunately the same test is still giving me ~1.5Mbps on my Thinkpad where I get 18-19 on my rMBP. Doesn't look like this was the key. – Adam Thompson Mar 28 '16 at 15:08
  • I just saw your updated post now. It fixed the issue for me, I can't thank you enough! Is TKIP just bad news with the new cards? – Adam Thompson Mar 31 '16 at 5:27
  • 1
    TKIP has been causing problems for a while, it even has some problems with Windows – Jeremy31 Mar 31 '16 at 10:04
0

I know that this is and old thread, but i found it and it helped immensely on fedora 28 desktop. The aggressive TX mod worked temporarily, but the real problem was the TKIP. If you have administrator access to your router, you can change the security to wpa2 (AES).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.