2

I'm trying to create a symbolic link to /home/user/www from /var/www/html so I can access the directory in my home folder from the URL: http://localhost/www/

I did: ln -s /home/user/www /var/www/html but when i access the URL above, the server returns 403 Forbidden.

The directory /home/user/www has permissions 775.

I'm on Ubuntu 14.04.

3
  1. Check /home/user/www and /var/www/html owners

Apache user\group must have access to /home, /home/user and /home/user/www paths

  1. Check Apache configuration:

look for FollowSymLinks option

<Directory /var/www/html>
    ...
    Options FollowSymLinks
</Directory>
2

Set permissions for /home/user to 711 and see if that helps any. Keep in mind... localhost/www won't exist unless you have a folder called www inside of the DocumentRoot.

Also, you're better off using ~/public_html over symlinking /var/www/html to something in your home directory. Bad practice/juju.

  • Unless I'm misunderstanding what you mean, ~/public_html isn't that useful unless you have multiple users. – user7000 Jun 12 '18 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.