I have read that xmodmap has been overridden by xkb since Fedora 23. I am using i3.

xkb seems really overwhelming when all I want to do is swap the windows key and alt key.

From xev the outputs are:

Windows Key

keycode 133 (keysym 0xffeb, Super_L)

Alt Key

keycode 64 (keysym 0xffe9, Alt_L)

I figured out how to do achieve this finally using setxkbmap.

setxkbmap -model thinkpad60 -layout us -variant int -option altwin:swap_alt_win

You can find the premapped options in /usr/share/X11/xkb/rules/evdev.lst

You will need to add this to your startup file because the command only last as long as the session you execute it in.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.