I have a Lenovo x120e that is not booting properly. When I turn it on, it just opens to a blank screen.

The machine is running Ubuntu 10.04.

Main Details: I shut the lid of the computer while it was running, and then opened it later and noticed that I couldn't get it out of suspend / hibernate mode. I subsequently powered it down by holding the power button. Now when I turn it back on, it just opens to a blank, black screen, as if it is still in suspend / hibernate.

Other Details:

  1. The 10.04 operating system was installed while this HD was in another laptop. Since I moved the HD into this machine, I have been booting another OS.
  2. I never updated the drivers in this operating system to work with this machine. (Does this matter for this particular situation / problem?)

What I have tried so far: I found the REISUB method here but I don't have a SysReq button.

What are my next steps to troubleshoot / solve this issue?

Note: This question was also posted on askubuntu but I didn't get an answer there that fixed the problem.

  • are you see the BIOS screen at all ? if not we should troubleshoot the hardware (and the software that relate to it e.g. BIOS) in order to get your bootstrap process again.
    – Hanan
    Dec 20, 2011 at 17:16
  • Have you tried booting with a live/rescue disk?
    – jasonwryan
    Dec 20, 2011 at 17:38
  • @jasonwryan I could not see the BIOS screen at all, so I couldn't get into a live/rescue disk.
    – Brian Dant
    Dec 20, 2011 at 19:34

3 Answers 3


I am assuming that the problem has a relation to the hardware (BIOS), and isn't related to the suspend issues you have had.

First of all check the brightness of your screen, sometimes you just need to use the right combination of keys to brighten it up.

If the above isn't helpful to you then I would suggest you try the following:

  • Go into the BIOS right after you boot up your computer by pressing the F1 key while the computer is booting.

  • While you are there try to exit out and boot the system again (sometimes it helps).

  • If the above doesn't help, try to change the BIOS settings to their defaults (you will see this option in the BIOS menu), then save and exit.

If the above doesn't help, I would suggest a more hardware-based approach by removing the CMOS battery (of course only after you have removed your main battery). Wait for 5 minutes and then boot the system up again.

You can see a picture of your computer's CMOS battery here (the blue circle), and a great guide from Lenovo on how to take apart your Laptop here (page 82). It shouldn't be too hard to do it, but it is your last choice.

  • I didn't try any of what you suggested, although I do appreciate the effort and useful answer. By the time I had checked this question again, I found a solution. Your post is good information for me for future reference. Kind of makes me want to just rip the machine apart anyway, for fun :)
    – Brian Dant
    Dec 20, 2011 at 19:40
  • I don't have enough rep to answer my own question yet (8 hour delay). The solution was to let the battery run down. The next time I pressed the power button, it booted into GRUB (before that I was literally powering up and down to a blank black screen).
    – Brian Dant
    Dec 20, 2011 at 19:46

Let the machine power-cycle itself by leaving it on until the battery dies. :-)

Holding the power button down to power-cycle would not spark the boot process. Letting the battery die caused the system to boot on the next power-on. I've never been happier to see GRUB!


Maybe your boot process tries to resume every time -- can you select "single user" or "rescue mode" in GRUB's boot menu? Choosing "Edit boot entry" (or similar, I can't remember) and removing what looks like resume=/dev/... could help, too. (Or add noresume, I don't know which procedure interacts with which suspend/resume solution (and which does Ubuntu use?))

  • I appreciate the suggestions, but I can't even get to GRUB's boot menu, or anything else that I can control. I literally can only manually power down and power back up, and this just brings me right back to a blank black screen. Thanks for your time.
    – Brian Dant
    Dec 20, 2011 at 15:14
  • Ok, this is weird. Sorry, I'm out of ideas.
    – sr_
    Dec 20, 2011 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .