3

I need to change the GDM display timeout from 10 seconds to something more forgiving. That is to say, my screen shuts off after 10 seconds in the lock screen.

I am running Fedora 23 with Gnome on a Desktop PC.

Note 1:

I am not talking about the typical display timeout after login setting. My issue is only in the lockscreen/gdm, before I log in.

Note 2:

To reproduce the short timeout you'll have to go to the login screen and press cancel. Afterwhich the display will sleep immediately. Once the screen is turned on again, the display will now respect a 10 second timeout, not the user set timeout. I'm sure there are more situations where the 10 second timeout applies... I need to increase it.

Background:

I have a very sluggish 4K TV as a monitor, it's fine with chroma compression, but extremely tricky to get working. For instance if I turn on my PC before the display, the display will never recognize the signal from the PC.

It takes about 10 seconds for the display to turn on, if it turns on, afterwhich GDM/Gnome/Fedora will turn it back off in 10 seconds... repeating the vicious cycle, I need GDM/Gnome/Fedora to give me more time to enter my password. This is not a Laptop after all.

  • 1
    You can remove the fedora part/tag as this is a (known) gdm3/gnome3 problem. That timeout is most likely hardcoded somewhere in g-s-d source code. See bug 710904 – don_crissti Mar 24 '16 at 23:55
  • @don_crissti Fedora is the only graphical distro I use. Thanks for the link. – Ray Foss Mar 25 '16 at 20:44
0

While as noted in the comments above this is a known issue, there is a more specific bug + patch being proposed to add support for the timer asked by OP and also UI to change it, see here: https://bugzilla.gnome.org/show_bug.cgi?id=773645

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.