3

How do I activate extra verbosity during boot, on Debian? I removed the quiet parameter and tried to add debug but it didn't help.

My problem is that my keyboard takes 2-3 min to activate so it slows my startup tremendously since I need to unlock a partition. I would like to get the message that pops out the moment my keyboard gets activated, but removing quiet doesn't print it.

  • What is going on that it takes 2-3 minutes to activate your keyboard? – fpmurphy Mar 23 '16 at 23:17
  • @fpmurphy1 that's what i'm trying to find out. I asked a question here on what might cause it but nobody was able to help – ChiseledAbs Mar 24 '16 at 8:23
3

Here is a list of all possible boot parameters: I've never used it, but try adding ignore_loglevel.

I previously mentioned verbose, but actually that only applies to other specific kernel options like acpi, as you can read, above.

With an understanding of your exact hardware, like it seems you have, you can go even deeper with this article on kernel hacking

This file is supposed to be included in /linux/documentationn according to an article on The Linux Documentation Project (TLDP.org)

  • If you want more help, please also add more details, because it sounds like a very interesting setup. – forgotstackxpassword Mar 23 '16 at 21:55
  • I added verbose parameter but it didn't help. I remember that one time I added the debug parameter to a fedora derived kernel and I had a very high number of messages during the boot, even while it was waiting for my input to unlock a partition. Here even after adding verbose it remains silent after it asks me for the key. – ChiseledAbs Mar 23 '16 at 22:21
  • I added some sources and suggestion to try options specific to your keyboard or also ignore_loglevel. I hope that as you dig deeper into this stuff, you'll find answers to several of your recent questions. – forgotstackxpassword Mar 23 '16 at 22:44
  • 2
    well ignore_loglevel nailed it thanks, looks like the system is cycling through all the usb ports and the keyboard gets activated only when it reach the good one. The cycling takes a long time it says usb 1-3: new high speed USB device number 5 using xhci_hcd; devce descriptor read/8, error -110 for each empty port and get stuck 10seconds on each one before it reaches the keyboard. – ChiseledAbs Mar 24 '16 at 8:30
  • @ChiseledAbs that is really interesting, thanks for the follow-up and marking the answer. Glad you're making progress. – forgotstackxpassword Mar 24 '16 at 20:22
0

Maybe the verbose (debugging) mode of the bootloader (is it grub?) will give you some hints.

To activate this press "c" during the bootloader menu (>Kernel Parameter) and then execute "set debug=all".

But since the bootloader is taking a long time before the keyboard becomes available to the system, the fault is somewhere else. To get more details during boot it is possible to use kernel-parameters for a higher verbosity level.

What about the connection Keyboard to the machine (Is it wired ? / USB ? / etc.)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.