1

I am trying to install Fedora 23 and continually getting a media check fail at 85.7%.

I am using a 32gb ADATA USB stick and making the bootable with dd.

sudo dd if=/Users/me/Downloads/Fedora-Workstation-netinst-x86_64-23.iso of=/dev/disk3 bs=1m

Here is the result of that command:

413+0 records in
413+0 records out
433061888 bytes transferred in 22.151491 secs (19550011 bytes/sec)

I have also checked the SHA-256 hash and it is identical to the one on getfedora.com (where I downloaded the iso from).

I have also tried reformatting the USB drive as well (it is formatted as FAT).

Any ideas? Can I safely go ahead with the installation anyways?

  • A memory check normally test the RAM. Checking the USB would, in my experience, be called a media check. Can you boot a from some other live distro and run the memory checker? And if the memory is bad, get it replaced, there is no guarantee that correct data doesn't get corrupted when copied to+from the bad memory. – Anthon Mar 23 '16 at 18:34
  • Sorry I meant to write media check fail (like the title). My fault. – Adam Thompson Mar 23 '16 at 18:40
  • And I almost never read the titles, sorry for that – Anthon Mar 23 '16 at 21:06
  • No problem! My fault. Would you say it's safe to continue since it is a media check fail? – Adam Thompson Mar 23 '16 at 21:24
1

It is not clear to me what this would be, but I would proceed with caution as ignoring a "bad read" might result in corrupted code on disk (it doesn't have to it as the check could be faulty).

First thing to do is trying a different USB port, especially downgrading to USB2 if you used a USB3 port before.

The other thing you can do if you have a machine with VirtualBox or other VM, is to install from that USB to a VM and see what happens.

If you have the time to buy another stick, do so and weigh the cost of spending against potential future trouble. You can of course re-use the stick for other things if it turns out that gives the same error (indicating it is something in the target machine) ¹.

If another stick gives the same error, it might be some USB problem or a memory problem. In that case test the memory extensively (memcheck) even if you tested the USB on the target machine (from an older installation e.g.) as it could be that the installer media check hits some other memory with a bad spot that the "manual" check doesn't hit.

If memcheck doesn't show anything, I would try a more minimal network installation if available. It might just be that the USB interface goes bad after reading a certain amount of bytes.

If you decide to proceed, it might be that you get more errors (if the USB hardware has some errors), but AFAIK the checksums of the individual packages will still be checked during the installation as well independent of the "global" media check.


¹ Reusability is the primary reason I use a SD cards for installation, as I can also use those in my camera, phone and ebook readers. I did find however that my laptop did not boot from my multi-card USB3 reader (with hub, from which my desktop PC and servers boot fine). My laptop would only boot from my single card USB2 SD card reader

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.