9

Methods I have tried:

None of these stop this process from being started when I log in:

me       1865  0.0  0.0 281816  7104 ?        Sl   10:50   0:00 /usr/bin/gnome-keyring-daemon --daemonize --login

This stops my Thunderbird from decrypting emails properly. When I kill the process, I can decrypt emails as expected but I don't want to have to do that every time I log in.

OS Information: Debian GNU/Linux 8.3 (jessie)

Can anyone help?

  • You could try removing the gnome-keyring package. – MagicFab Mar 23 '16 at 15:32
  • This is dangerous advice. Unfortunately, on many GNU/Linux distributions, using your package manager to remove the gnome-keyring package will also remove the gnome package and numerous others. (In an ideal world, removing the gnome-keyring package would indeed be the right answer, but in the real world, unless you want to uninstall your whole desktop environment, you should evaluate other solutions.) – sampablokuper Jan 22 '18 at 7:18
6

Actually the gnome-keyring-daemon in several cases is started via X login using the PAM (Pluggable Authentication Modules) files, but there is other ways like autostart files too GnomeKeyring/RunningDaemon. You can look in detail about the integration of PAM on official documentation. But in general you just need to detect which desktop manager are you using and delete the entries on your /etc/pam.d/<desktop_manager>.

In my case, I use the lightdm. So I have a PAM file called /etc/pam.d/lightdm which has that contents:

❯ cat /etc/pam.d/lightdm
#%PAM-1.0
auth        include     system-login
-auth       optional    pam_gnome_keyring.so
account     include     system-login
password    include     system-login
session     include     system-login
-session    optional    pam_gnome_keyring.so auto_start

Deleting or comment the entries which call the pam_gnome_keyring.so module, located on /lib/security, you can accomplish the full disable of the daemon on login. To be sure, look to /etc/xdg/autostart and ~/.config/autostart for files with the pattern gnome-keyring-*.desktop and append Hidden=true on each file to disable that component as well.

How To on antiX 17.1 (based on Debian 'stretch')

NOTE: This, or something close to it, should work for most Debian-based systems.

  • For each user for which gnome-keyring-daemon should not start on login...

    • For each service for which there is a file like...
      /etc/xdg/autostart/gnome-keyring-*.desktop
      
    • Create a file of the exact same name in: ~/.config/autostart
      • Containing only...
        [Desktop Entry]
        Hidden=true
        
      • Such as...
        ~/.config/autostart/gnome-keyring-pkcs11.desktop
        ~/.config/autostart/gnome-keyring-secrets.desktop
        ~/.config/autostart/gnome-keyring-ssh.desktop
        
      • Insure that each file is owned by their respective user and has permissions 644 (rw-r--r--)
    • OPTIONAL: Disable gnome-keyring-daemon processes for 'login'

      • The above per-user changes still allow 1 or 2 gnome-keyring-daemon processes to be started at login. But they will automatically stop after a couple of minutes if no per-user processes are started. Thus, alteration of these /etc/pam.d files is not really necessary but is provided for completeness.
        • Comment out gnome-keyring-daemon lines in the PAM config file for the display manager (antiX uses slim): /etc/pam.d/slim
          # auth      optional  pam_gnome_keyring.so
          # session   optional  pam_gnome_keyring.so auto_start
          
        • Comment out gnome-keyring-daemon lines in the PAM config file: /etc/pam.d/common-password
          # password  optional  pam_gnome_keyring.so
          
    • Reboot

  • 1
    It should be the accepted answer. Thanks. I use so I've commented the lines in the files /etc/pam.d/gdm-* – Kevin Lemaire Jun 1 '18 at 10:31
  • Great to know that works for you too, @KevinLemaire! – Manoel Vilela Jun 2 '18 at 17:25
4

For simple disabling (rather than removing), how about removing execute permission? (You will need appropriate permissions, so you may need to prefix sudo).

$ chmod -x $(type -p gnome-keyring-daemon)

You could also kill the process if its currently running:

$ pkill gnome-keyring-daemon
  • 2
    Technically that is correct, but pretty horrible. You will end with errors poping up in journalctl and/or syslog. Also, you need root to perform those commands (that would be wise to mention in the answer) – grochmal Jul 28 '16 at 15:46
  • 1
    Very fair point. However I would add that there will only be a few log lines---not enough to cause problems by drowning out real logged events---so you may be willing to accept this cost at least until a more elegant solution is found. (edited answer to reflect need for permissions) – user1093043 Jul 28 '16 at 16:00
0

Open System Monitor, in processes tab scroll down and select gnome-keyring-daemon, and click end process.

I'm using Kali GNU/Linux Rolling and it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.