3

I am trying to install Octave on CentOS. After running

sudo yum install octave
./configure F77=gfortran

I got this error:

configure: error: A BLAS library was detected but found incompatible with your Fortran 77 compiler settings.

After some googling followed up with this:

sudo yum-builddep octave
sudo yum install lapack64-devel lapack64
sudo yum install libblas-dev libatlas-dev liblapack-dev

And yet I'm still getting the same BLAS incompatibility error.

Could you advise on how to proceed?

2
  • What happens if you use F77=g77 instead? (You may have to install the compat-gcc-34-g77 (or similar name for your version of CentOS) package.)
    – John
    Mar 22, 2016 at 19:09
  • @John: getting the same error: configure: error: A BLAS library was detected but found incompatible with your Fortran 77 compiler settings.
    – Michael
    Mar 22, 2016 at 20:33

1 Answer 1

1

I was encountering the same issue for a significant amount of time until I installed the following packages:

sudo yum install lapack-devel
sudo yum install atlas-devel

Once those were installed, ./configure ran without any errors. I didn't have to use F77= either, but that may differ in your situation.

From there, you should be able to run make && make install without errors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .