I'm having trouble getting my wireless card seen in debian squeeze. iwconfig only shows eth0 and l0 but no wlan0. ifconfig wlan0 up says theres no such device.
I compiled a backport kernel and I now have "2.6.39-bpo.2-686-pae". I downloaded the rtl8191se driver from the Realtek site. It said it needs kernel version 2.6.35 or above. So now that I have 2.6.39 all should be fine. However when I run make in the firmware driver it says

make entering directory lib/modules/2.6.39-bpo.2-686-pae/build
no rule to make target 'modules'

Is there a problem with my make? I installed i386 packages as theres no i686 packages on the Debian site. However, my kernel is i686 it seems. Is that a problem?

  • 1
    More steps, please. Where did you unpack the source files? What instructions did you follow, if any? In what directory did you type make? Dec 19, 2011 at 17:23

1 Answer 1


It looks like this is in 3.0 onwards. See Linux Kernel Driver DataBase.

So what you need to do is

  1. install a 3.0 kernel or later. Debian has sources and binaries for 3.1 and 3.2, 3.1 in testing and unstable and 3.2 in experimental. See linux source package page. The linux-2.6 source package name is confusing, but it looks like they haven't changed the name yet to 3.x.

  2. Install the firmware-realtek package.

You could of course use an external kernel source, but you are better off using a Debian kernel. Note that this driver is probably already enabled in the binary kernel as a module, so in that case you don't need to do anything except install the firmware. If you are compiling from source, make sure to select this module to build.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .