I have two Mac OS X clients, both running XQuartz 2.1.6 (xorg-server 1.4.2-apple33). When I SSH into a remote linux system enabling X11 forwarding and launch gnome-terminal, on one Mac the terminal looks correct while on the other, the fonts are all screwy!

[jnet@Stan ~]$ ssh -X jnet@kyle.local gnome-terminal produces: Lookin good!

powerbook:~ hp$ ssh -X jnet@kyle.local gnome-terminal produces: OH MY GOD, MY EYES!!!!!

The problem goes away on the powerbook if I zoom in twice: Looks OK only because the image is scaled down to fit

Edit: This affects a number of apps, not just gnome-terminal. It also affects Thunderbird, for example.

  • I would love to tag as [x11] [fonts], can anyone help a new user out? – Josh Oct 4 '10 at 16:05
  • Seven years later, this seems like a Wisdom of the Ancients issue. Did you happen to figure it out? – mpontillo Nov 29 '17 at 3:49
  • Sadly @mpontillo I gave up, and now I am using XQuartz. – Josh Nov 29 '17 at 3:51

Looks like a font problem - run Font Book.app, click All Fonts, then select all the fonts in the middle pane (cmd-a) and choose File -> Validate Font from the menu. This will produce a report of any fonts with issues.

If you find a broken font file, look where it is residing:

  • if it's a system font (any path not in /Users), replace it from install media or the working Mac (easier)
  • if it's a user font (any path in /Users), delete it - the system fonts should be sufficient, but user fonts take precedence, so if the user installed some borked font it can cause this.

I was able to improve things by doing the following:

On my Ubuntu system, I ran:

xrdb -query -all

This resulted in the following output:

*customization: -color
Xcursor.size:   24
Xcursor.theme:  DMZ-White
Xft.antialias:  1
Xft.dpi:    96
Xft.hinting:    1
Xft.hintstyle:  hintslight
Xft.rgba:   rgb

I then took that output and created a ~/.Xresources file on the Mac, using as its contents the above output of xrdb -query -all. Then, on the Mac, I ran:

xrdb ~/.Xresources

... which I understood should cause the settings to take effect in the current X server. Subsequently, the font rendering seemed better, though it still isn't perfect.

Thanks to this answer for providing some hints about the a possible fix.

  • Nice, glad you found at least a partial fix. I don't have that hardware anymore so I can't test it anymore, but +1 for good relevant info! – Josh Nov 30 '17 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.