1

I have an odd one. A RedHat 7 server, with an apache server that runs just fine. I can start it with systemctl start httpd. Developers had me run it as a different user (intersys instead of apache). Now when I FTP to the server as that user, (intersys) actually when I disconnect the FTP session, it kills httpd. I see this error in /var/log/httpd/error_log:

[Mon Mar 21 10:02:49.308506 2016] [mpm_prefork:emerg] [pid 13734] (43)Identifier removed: AH00144: couldn't grab the accept mutex
[Mon Mar 21 10:02:49.611064 2016] [core:alert] [pid 12683] AH00050: Child 13726 returned a Fatal error... Apache is exiting!

I have tried changing the shell of "intersys" to various things, no help.

restart always works fine. I think something is sending httpd a hangup signal. any ideas about how to stop that?

  • For reference, mention the version of Apache. – user156990 Mar 21 '16 at 15:25
0

If your Mutex directive within httpd.conf is set to pthread, try changing it to fcntl.

  • where do I set AcceptMutex? This is apache 2.4, I dont' see that parameter in 2.4 . – Tony R Mar 21 '16 at 15:14
  • I have tried various things as the shell for "intersys": /sbin/nologin, /bint/true. /bin/bash. all give the same result. – Tony R Mar 21 '16 at 15:15
  • If this is not set the default value is loaded, just specify AcceptMutex fcntl in the httpd.conf and test again. – hub Mar 21 '16 at 15:24
  • 1
    For Apache 2.4 the declaration is "Mutex". serverfault.com/questions/755823/… – user156990 Mar 21 '16 at 15:27
  • Oh, my fault, will edit now. – hub Mar 21 '16 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.