1

I've been trying to install my wireless adapter quite a while, I've a Surface Pro I and already gave up on getting ndiswrapper to work because it says that it can't load the driver "mwlu97w8x64" even though I've used it before two years ago along with ndiswrapper as well and didn't have any problem then so I'm trying to install the right firmware this time but the mlan(not wlan) interface doesn't show when I do ip link or ifconfig not even less iwconfig. I've already added the firmware to /lib/firmware/mrvl/...

root@rinaldi:/home/rinaldi# modinfo mwifiex_usb
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/mwifiex/mwifiex_usb.ko
firmware:       mrvl/usb8897_uapsta.bin
firmware:       mrvl/usb8797_uapsta.bin
license:        GPL v2
version:        1.0
description:    Marvell WiFi-Ex USB Driver version1.0
author:         Marvell International Ltd.
srcversion:     2D6C6069607126D19ADC681
alias:          usb:v1286p2046d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1286p2045d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1286p2044d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1286p2043d*dc*dsc*dp*ic*isc*ip*in*
depends:        mwifiex,usbcore
intree:         Y
vermagic:       3.16.0-4-amd64 SMP mod_unload modversions 

/etc/network/interfaces

root@rinaldi:/home/rinaldi# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
auto mlan0
iface lo inet loopback
iface mlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

can I've the wireless card working with just the right firmware installed? what the kernel does look for to start the wireless card? How would you proceed?

lsusb

Bus 002 Device 005: ID 045e:0794 Microsoft Corp. 
Bus 002 Device 004: ID 03eb:8209 Atmel Corp. 
Bus 002 Device 003: ID 045e:0799 Microsoft Corp. 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 045e:0795 Microsoft Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05e3:0616 Genesys Logic, Inc. 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 1286:2044 Marvell Semiconductor, Inc. 
Bus 003 Device 005: ID 413c:2107 Dell Computer Corp. 
Bus 003 Device 004: ID 046d:c077 Logitech, Inc. 
Bus 003 Device 007: ID 0bda:8179 Realtek Semiconductor Corp. 
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0

Newer firmware may help

wget http://git.marvell.com/?p=mwifiex-firmware.git;a=blob;f=mrvl/usb8797_uapsta.bin;h=0ce6c4ec307880d34bbef3b6ccd359617914f156;hb=e92f8b3f65443764297b947b1843955d9a65dde7
sudo mv /lib/firmware/mrvl/usb8797_uapsta.bin /lib/firmware/mrvl/usb8797_uapsta.bin.bak
sudo cp ./mrvl_usb8797_uapsta.bin /lib/firmware/mrvl/usb8797_uapsta.bin

Reboot

  • Thank you very much Jeremy for your reply, I'll be trying hopefully by the end of this week and I'll post here them. – Rinaldi Segecin Apr 12 '16 at 12:20
  • Progress! I was able to get an Ip Address with mlan0 but it doesn't transfer data, and it's not internet connection to blame because I can use it when I'm on windows. – Rinaldi Segecin Apr 22 '16 at 8:38
  • I copied the pcie8897_uapsta.bin and sd8897_uapsta.bin as well found on the repository you shown to the mrvl directory rebooted and now it's working. Thank you very much Jeremy31. – Rinaldi Segecin Apr 22 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.