7

Hello I can't find the option to reassign shortcuts in xfce4-terminal 0.6.3. I'd like to reassign ctrl+c to copy, ctrl+v to paste and ctrl+shift+c to kill process. I know I can do that easily under gnome-terminal but since I'm using xfce I would like to avoid installing all the dependencies for gnome-terminal. Any idea on how to achieve that ?

2
  • You might want to consider konsole which is a lot more configurable than xfce4-terminal or gnome-terminal.
    – Gray
    Feb 15 '18 at 23:26
  • 2
    @Gray - People use Xfce to keep a light clean system, and installing konsole (and other KDE specific tools) in Xfce is really a bad idea, it comes with about 117 dependencies, while the added value is minimal. There are other alternatives anyway.
    – cipricus
    Feb 23 at 7:54
4

The accepted answer doesn't work anymore (for example with xfce4-terminal 0.8.7.4 on Lubuntu 18.04.2) because of a GTK3 change, as described on How to change key bindings for xfce-terminal?. It seems that the only way to change the keyboard shortcuts is by modifying the configuration file, ~/.config/xfce4/terminal/accels.scm.

Open the file, search for “copy”, and replace ; (gtk_accel_path "<Actions>/terminal-window/copy" "<Primary><Shift>c") with (gtk_accel_path "<Actions>/terminal-window/copy" "<Primary>c").

That is: change the shortcut, but also remove the semicolon at the beginning of the beginning of the line. (It's a comment delimiter.)

enter image description here

The same for “paste”: replace ; (gtk_accel_path "<Actions>/terminal-window/paste" "<Primary><Shift>v") with (gtk_accel_path "<Actions>/terminal-window/paste" "<Primary>v").

enter image description here

Restart the terminal.

0
2

In xfce terminal go to Edit, hover your mouse over Copyand press ctrl+c.

Same goes for paste.

Kill process gets automatically reassigned to ctrl+c+shift.

3
  • 3
    this is not working with xfce-terminal 0.8.4
    – Curious
    Nov 13 '17 at 21:02
  • I found that this worked for Alt-C but I couldn't get Alt-V to be assigned. Alt-T (for new tab) worked. Alt-A (for select-all) didn't work. I couldn't find the pattern. I ended up switching to konsole (++) whose shortcuts were assignable in the preferences.
    – Gray
    Feb 15 '18 at 23:26
  • 1
    The procedure you are describing belongs to GTK2 windows. In xfce that does not work. Understand that xfce could start gnome2 windows. So, you are probably talking about gnome-terminal, not xfce-terminal.
    – ImHere
    May 15 '20 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.