2

I am not sure if I am asking this question at the right place, but I am trying to set (decrease) the mouse sensitivity on my Debian system (it's way too fast), sadly I can't make it work.

My mouse is a Logitech MX518, the system:

Linux desktop 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u4 (2016-02-29) x86_64 GNU/Linux

I googled it already, but none of the suggestions are working.

For example the result of xinput list:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Microsoft Wired Keyboard 600              id=10   [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Microsoft Wired Keyboard 600              id=9    [slave  keyboard (3)]
    ↳ Eee PC WMI hotkeys                        id=11   [slave  keyboard (3)]

So it has the ID 8. I checked the details too (xinput list-props 8):

Device 'Logitech USB-PS/2 Optical Mouse':
    Device Enabled (144):   1
    Coordinate Transformation Matrix (146): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Product ID (263):    1133, 49233
    Device Node (264):  "/dev/input/event0"
    Evdev Axis Inversion (277): 0, 0
    Evdev Axes Swap (279):  0
    Axis Labels (280):  "Rel X" (154), "Rel Y" (155), "Rel Vert Wheel" (272)
    Button Labels (281):    "Button Left" (147), "Button Middle" (148), "Button Right" (149), "Button Wheel Up" (150), "Button Wheel Down" (151), "Button Horiz Wheel Left" (152), "Button Horiz Wheel Right" (153), "Button Side" (267), "Button Extra" (268), "Button Forward" (269), "Button Back" (270), "Button Task" (271), "Button Unknown" (266), "Button Unknown" (266), "Button Unknown" (266), "Button Unknown" (266)
    Evdev Scrolling Distance (282): 1, 1, 1
    Evdev Middle Button Emulation (283):    0
    Evdev Middle Button Timeout (284):  50
    Evdev Third Button Emulation (285): 0
    Evdev Third Button Emulation Timeout (286): 1000
    Evdev Third Button Emulation Button (287):  3
    Evdev Third Button Emulation Threshold (288):   20
    Evdev Wheel Emulation (289):    0
    Evdev Wheel Emulation Axes (290):   0, 0, 4, 5
    Evdev Wheel Emulation Inertia (291):    10
    Evdev Wheel Emulation Timeout (292):    200
    Evdev Wheel Emulation Button (293): 4
    Evdev Drag Lock Buttons (294):  0

As you can see there is no Device Accel Constant Deceleration or Device Accel Velocity Scaling so I can't set those properties.

I tried changing the mouse sensitivity in the Settings -> Mouse & Touchpad but it does nothing. I also tried to update the xset with different values, or set-up a pointer device in xorg, but again, nothing.

Is it possible that my mouse wasn't recognized properly? If so, does anybody know how to fix this?

Edit: I forgot to mention that I can change the sensitivity with the buttons on the mouse (the plus and minus sign above and below the scroll), but after a couple of seconds it just goes back to the highest sensitivity.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.