0

I have a big problem under Xfce4, namely when I try to start a program using alt+F2, I'll start typing xfce4-terminal and before I finish it, it suggests the end of the sentence--but usually you accept the suggestion by pressing tab--here I have to move my hand all the way to the right arrow because tab is just moving the focus from the text area to the other buttons.

Does anyone know how to fix this issue ?

  • That "big problem" may be solved by (1) always having around a terminal emulator to type various commands in, or (2) hitting enter right after you see the suggestion, or hit <End> to add some options. – Andrew Miloradovsky Mar 18 '16 at 22:19
  • @AndrewMiloradovsky problem is, my friend, when I try to type in xf it first complete xfce4 - then ter and only then I can hit enter. Wouldn't be asking otherwize... alternatively do you know how to alias terto xfce4-terminal ? – ChiseledAbs Mar 18 '16 at 22:30
  • Aliases are used in shells, not in desktop environments; in DE's you're supposed to use the mouse to launch the programs... Can't you just start a terminal (via the menus or automatically) at login and do not close it?... – Andrew Miloradovsky Mar 18 '16 at 22:37
  • As with any filename completion, you have to type enough of the command-name or filename to disambiguate it from other matches. In the case of xfce4-terminal, you have to type at least xfce4-te if you want to just hit enter to execute it rather than select it from the pop-up menu with a mouse. Alternatively, have an icon for xfce4-terminal in your panel or on your desktop, or configure your xfce session so that it automatically starts a terminal on login. – cas Mar 19 '16 at 1:44
  • 1
    And I know that xfce allows one to set keyboard shortcuts to open applications. So it's not difficult to have Super+T open your favorite terminal, Super+F open Firefox, etc etc etc – DK Bose Mar 19 '16 at 1:49
1

Alt-F2 in xfce4 does not support TAB completion, but it does allow you to hit the up-arrow key to select from the popup-menu via the keyboard.

Try typing Alt-F2 followed by xfceUp-ArrowEnter to finish the command-completion, and then Enter again to Launch the completed command.

On my system, that will run xfce4-terminal because it is the bottom-most entry on the popup. This may be different on your system, just use the up and down arrows to select xfce4-terminal.

Down-Arrow also works, but starts with the selection cursor at the top of the popup menu rather than at the bottom.

1

There is an alias defined by default for the terminal it's ! so you just need to press : Alt-F2-!-Enter

More broadly you can define your own aliases by going to xfce-appfinder - Preferences - Actions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.