0

I'm currently having an issue trying to give a user the permissions that the 'root' user has, which is to modify anything in the / directory. I've changed the /etc/passwd file but still no luck. I've also went into visudo and did the pi ALL=(ALL:ALL) ALL, and that still didn't solve my issue.

  • What did you change in /etc/passwd? When you added the pi entry to the sudo config file, what command did you then run to try and achieve what you wanted to (i.e. to create, edit or delete a file?) and what error did you get. – EightBitTony Mar 18 '16 at 15:51
  • I didn't run any command @EightBitTony, I tried editing/modifying/deleting a file in the "/" directory and nothing happened. – FivePixels Mar 18 '16 at 16:14
0

possibly a duplicate of start file manager in terminal window wheezy

depends on your file manager. for example, run from terminal:

sudo pcmanfm &>/dev/null &
  • This isn't what I'm wanting. I just want to give a user access to edit in the "/" directory. Each time I try to modify a file it always gives me a permission denied unless I'm on root. I want the same permissions as root and don't want to have to sign in as root user every single time I want to put a file or files into that directory. – FivePixels Mar 18 '16 at 17:06
  • ok, sorry. Have you looked into raspberry's documentation on root ALL=(ALL:ALL) ALL and bob ALL = NOPASSWD: ALL ? – ingli Mar 18 '16 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.