3

I just installed (actually I did so three times today) debian on a separate partition in my Win10 laptop (Asus K46CB), but though the installation went smoothly, no OS selection menu comes up upon boot, and Windows loads itself as it always has - i.e. I can't boot to debian at all over this lack of grub menu.

I attempted to run Ubuntu live CD's boot repair utility, but it spit out grub-efi purge cancelled.

I also tried using EasyBCD on Windows to see if I could add debian as an option in the Windows boot menu, but EasyBCD refuses to work because it's a UEFI system. Though EasyBCD should work with UEFI with a few changes, there are no options in my bios/uefi utility to change anything to "legacy mode", let alone disable "secure boot".

I'm at a loss as to what else to try: I just wanted to have dual-boot work as it does in my ubuntu/win10 desktop.

1

I once again reinstalled debian, but, this time, I actually chose to boot the disc as UEFI during boot/setup. Installation ran smoothly and in the end everything worked perfectly.

That was it!

0

Most of the times ASUS laptops doesnot recognise the linux bootable drives.It didnt work for me at the start.

First, get into BIOS and switch-off SECURE-BOOT options.

And Restart the PC.

I suggest you to download a clean iso from the distros may be a new ubuntu 1x.xx iso. (# In Windows environment) Then take a pendrive and make it bootable using RUFUS software then download 7zip and install it then get into the boot folder present in bootable drive you have created using RUFUS. Now using 7zip open the *.img file and copy the contents into the bootable drive which you have created using RUFUS.

Restart the PC and install the Linux and you'll be getting a Linux grub now.

  • As I said, there is no secure boot option in my BIOS menu. – zynphull Mar 21 '16 at 16:33
  • try updating your bios version generally all system which come with win 8 or higher come with uefi bios and uefi bios contains secure boot option...if u got ur pc came with dos initially u might not be having a uefi bios .try updating urs... – Dhawal S Mar 23 '16 at 14:57
  • No, this is a brand-new laptop, it came with Win8, and is definitely UEFI, but there is no 'secure boot' option. – zynphull Mar 25 '16 at 15:32
0

You should have the functionality (in UEFI firmware) to reorder boot menu items - move up/down (and even add new boot menu items).

I speak pure UEFI firmware setup functionality.

Usually you go to firmware setup using F2-key, could be another key which is listed on power-up.

Put Linux as first (top) boot candidate in NVRAM boot entries. GRUB can chain load Windows on BIOS and on UEFI!

Note: EasyBCD cannot create Windows/Linux dual-boot on UEFI. Don't waste time.

  • This was very close to the heart of the matter, I think, that is, UEFI was the issue, I had to actually boot the debian install disc as UEFI for the installation to work. Thanks! – zynphull Mar 25 '16 at 15:32
-1

Run this command under Debian:

sudo update-grub
  • I cannot boot to debian. If you mean to say that I should run this command in a shell in debian's repair menu, I tried, and it didn't work. – zynphull Mar 18 '16 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.