I have two hard drives on my computer. On one of them I have installed linux (elementaryOS) and on the second one I store some of my data. I have made fstab entry to auto-mount this drive and everything works fine until I unplug that drive to move it to another computer. After that I cannot load system at all. All I see is a blinking cursor.

my fstab entry:

UUID=uuid  /media/user/DATA  ntfs-3g defaults,nofail,x-systemd.device-timeout=1  0  2

what is wrong with that?

  • 1
    Do you see blinking cursor right after POST boot? Have you checked your BIOS/UEFI settings for boot order? Make sure PC at least tries to boot your OS.
    – user996142
    Mar 17, 2016 at 18:18
  • Yes, I see blinking cursor. I have checked UEFI settings and boot order is set to hard drive with linux. Mar 18, 2016 at 15:58

1 Answer 1


fstab is used to mount static disks at startup (usually internal disks or disks that will never get removed).

(my suggestion)

If you're looking to mount the disk on startup if it is present, I would suggest using cron:

From crontab -e (edit your crontab), add the following line at the bottom:

@reboot mount -U <your-UUID-her>

Just remember to take out the offending line from fstab.

  • This is static internal disc. I don't realy move it very often, but I want to be sure, that when some day it will be broken I will be able to run my os with no problems. I found info about options I have used in fstab entry in archlinux wiki: wiki.archlinux.org/index.php/fstab Tak a look at "External devices" section. I am also wondering if there is better and more safe method than fstab like cron (as you suggested), rc.local or autostart script. What do you think about it? Mar 18, 2016 at 16:17
  • If it's an old internal disk that might go anytime soon I would strongly suggest cron. It's what I do when I discover a disk is starting to act weird, as a precaution. I prefer cron over other methods because it's quite universal (works with all Unix systems). Mar 19, 2016 at 1:41
  • finaly I've decided to make my own mounting script executable on startup: cyberciti.biz/tips/… and it works perfectly as I wanted :) bye bye fstab method ;) Mar 26, 2016 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.