1

Hello I installed Debian, the entry in the NVRAM made by the installer isn't working so I boot it with refind using the following kernel parameters :

rw nomodeset root=/dev/mapper/cryptroot initrd=/initrd-ver.img cryptdevice=/dev/nvm0n1p4:cryptroot 

Problem is that when it comes for asking to unlock the disk the keyboard isn't working (won't accept any input).

The keyboard is a USB keyboard with embbeded firmware (Strix Tactic Pro).

How do I do ? I've been thinking to change the hooks in the initramfs system and put the keyboard hook at the beginning but I have no idea what to do since the initramfs thing seems so much difficult and the documentation for it very obscure contrary to the archlinux /etc/mkinitcpio.conf / mkinitcpio -p linux that I got to work easily thanks to their great wiki.

Could someone explain me how to activate the keyboard when the system prompt for the password to unlock encrypted partition or how to rebuild an initrd.img file with the keyboard hook that allows the keyboard to work at prompt?

After 1min or 2min of idle it starts to work alone, but if you want to inform me about the debian initramfs system and hooks or tell me why it is so slow for the keyboard to get responsive you're welcome.

  • What kind of keyboard is it? A basic USB keyboard or something else? – Gilles 'SO- stop being evil' Mar 17 '16 at 23:10
  • @Gilles it's a usb keyboard with embbeded firmware (strix tactic pro) – ChiseledAbs Mar 18 '16 at 8:28
  • Do you know if it needs some special driver support in Linux? It's rare for a keyboard to need that (most work with a standard USB keyboard driver), so maybe Debian's scripts aren't set up for it, and they show the prompt before making sure that the extra keyboard driver is initialized. – Gilles 'SO- stop being evil' Mar 18 '16 at 16:16
  • @Gilles well I don't know, I don't think so since it's working fine in the UEFI – ChiseledAbs Mar 18 '16 at 17:28
  • User's added some info that might help solve this, at this related post @Gilles – forgotstackxpassword Mar 24 '16 at 20:27
1

TL;DR: sudo rm /etc/initramfs-tools/conf.d/driver-policy && sudo update-initramfs -u

The reason is because during the Debian installation, the installer ask you would you like to include most drivers in your initramfs or only the needed drivers, and I selected only needed.

It worked fine, until I get an USB keyboard and external monitors. I have two passwords during boot, one set in the UEFI/BIOS to boot the laptop, another is for the Debian LUKS encrypted root. Although the USB keyboard worked fine for the laptop boot password set in the UEFI/BIOS, it cannot be used to enter the password to unlock the encrypted root partition. I had to open the lid and use the keyboard on the laptop to enter the 2nd password.

It turns out that the USB keyboard driver (or maybe all USB drivers, since during the Debian installation, I didn't have any USB devices connected to the laptop) is not included in the initramfs, therefore the USB keyboard cannot be used before the root partition is unlocked.

So, change the MODULES=dep to MODULES=most and update the initramfs should fix it. The MODULES=most should exist in /etc/initramfs-tools/initramfs.conf, and override by /etc/initramfs-tools/conf.d/driver-policy created by the Debian installer. Therefore, simply remove the file and update initramfs will fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.