The system often just freezes up without any warning, it doesn't gradually start getting slower or something like that, and every time I look the avarage system load is below 20% (usually not even 10%).
When looking at dmesg, there's one thing that always seems to come back though. The message composite sync not supported. These freezes are getiing indredibly annoying as I always lose all my work I haven't saved yet, and the last time it froze up happened while I was saving something (I don't think I need to tell you that that file was gone).
Can annyone give me any pointers (and hopefully solutions as well), to where this problem lies? If you've found something that might be the cause, but you don't know how to fix it, just put it in the comments, please. That way I can do a bit of research myself maybe.

Dmesg: http://pastebin.com/ZeiULvSK
... And I thought there was a kernel.log file in /var/log, but apparently I was wrong.

More recent dmesg: http://pastebin.com/CXETguti
This is the output taken right after closing VVVVVV (a game).
I found out 2 things today that both point to the same thing... The dmesg is full of Nouveau errors, and games lag like hell, and some don't start at all. The conclusion is that it refuses to use the NVidia drivers.
Help on getting them to work would be nice as well. More info on that: https://askubuntu.com/a/83995/18953

When adding nomodeset to my kernel line in GRUB I'm stuck with a small screen resolution, limited amount of colours (gradients look like crap), the screen becomes laggy, but the errors don't crop up anymore in dmesg. I've experienced no freezes with this parameter added, but I haven't worked longer than 10 minutes with nomodeset because making mindmaps on a small resolution is annoying.
My graphic card is an NVidia Quadro NVS 110M.

robin@robin-Latitude-D620:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)
robin@robin-Latitude-D620:~$ sudo lshw -class display
[sudo] password for robin: 
       description: VGA compatible controller
       product: G72M [Quadro NVS 110M/GeForce Go 7300]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:16 memory:ed000000-edffffff memory:d0000000-dfffffff memory:ee000000-eeffffff memory:ef000000-ef01ffff

What I did to install the NVidia drivers
Installed nvidia-current with Jockey, removed it again (had to try 2 times, first time failed), added a PPA for a newer version, installed nvidia-current again (this time with the terminal), rebooted.

  • Follow this question to solve problems with loading the proper nvidia driver.
    – Bruno Pereira
    Dec 5, 2011 at 17:19
  • This sounds like a hardware issue, to be honest. I've recently had a spate of lockups and hard-crashes (black screen with reboot), segfaults, etc, to the point where my machine now just refuses to boot Ubuntu. It will get past grub or the SYSLINUX bootstrap on the LiveUSB (tried Oneiric AND Natty), but after that I just get a blinking text cursor and nothing further... Windows still boots and runs. It's most infuriating. Suspect I will be shelling out for some new hardware...
    – Adrian
    Dec 5, 2011 at 17:25
  • Can you ssh into the machine after it froze?
    – cweiske
    Dec 5, 2011 at 20:01
  • @BrunoPereira The questin you referenced to tells me to run sudo dkms remove nvidia from the terminal, but this doesn't work. Error! Invalid number of parameters passed. Usage: remove -m <module> -v <module-version> --all or: remove -m <module> -v <module-version> -k <kernel-version>
    – RobinJ
    Dec 6, 2011 at 8:32
  • @fossfreedom Done. The problem with the NVidia drivers is that I installed a newer version (askubuntu.com/questions/83140/x-plays-a-gambling-game/…) because the old ones screwed up X. I thought the problem was fixed, but this seems the only reason the problem was solved was because it didn't load the NVidia drivers anymore, and in stead just used the Nouveau drivers.
    – RobinJ
    Dec 6, 2011 at 14:37

2 Answers 2


Maverick was particularly prone to graphics freezes with the standard Open-Source nouveau drivers.

You can uplift you X-System using the X-Updates PPA

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get upgrade

You can then install the latest NVIDIA drivers.

As you have noted, the Open-Source drivers still seems to take precedent over the NVIDIA drivers.

One-way to force the use of the NVIDIA drivers is to black-list the open-source drivers:

To do this:

  • Run gedit as root: gksu gedit (either run this in a terminal or in the run dialogue (ALT+F2)).
  • Then open the following file: /etc/modprobe.d/blacklist.conf .

    • To this file add the following line:

    blacklist nouveau

  • Now open the following file: /etc/modprobe.d/nvidia-graphics-drivers.conf

  • Add these lines to the file


   blacklist nouveau  
   blacklist lbm-nouveau
   blacklist nvidia-173  
   blacklist nvidia-96  
   alias nvidia nvidia-current

Now install the nvidia-current driver:

sudo apt-get install nvidia-current

One happy side-effect of using the nvidia drivers rather than the old maverick open-source drivers is that the temperature/battery usage is greatly reduced.


alternative force usage of nvidia driver

The following will actually remove the nouveau driver before reinstalling the nvidia driver (again).

sudo apt-get --purge remove xserver-xorg-video-nouveau 

Now make sure you have the headers installed before reinstalling the nvidia driver

sudo apt-get install linux-headers-$(uname -r)
sudo apt-get install --reinstall nvidia-current

Now rename your xorg.conf before recreating the file:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
gksudo nvidia-xconfig

If nvidia-xconfig still gives you an issue run,

gksudo nvidia-settings


if you get black-screens then do the following to reverse:

First, boot with recovery and choose terminal with networking

Then rename the xorg.conf file

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup2

The reinstall the opensource driver:

sudo apt-get install xserver-xorg-video-nouveau 

You may or may not also have to remove the "blacklist" lines added at the top of this answer.

  • Thanks, I'll try it out :p Erm, does it matter that I still had the NVidia drivers installed when I did this? And do I need to reinstall them now? I already had the drivers from that PPA.
    – RobinJ
    Dec 10, 2011 at 14:42
  • Version: 290.10-0ubuntu1~maverick~xup1
    – RobinJ
    Dec 10, 2011 at 15:07
  • Erm... I did what you said to force it to use the NVidia drivers, but it doesn't seem to have worked. When I run nvidia-settings it says You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server. And Nouveau is still spamming my dmesg. Also, the nvidia-xconfig command doesn't exist.
    – RobinJ
    Dec 10, 2011 at 20:05
  • Erm... I think my laptop is playing games with me, seriously xD I removed the package, and reinstalled the NVidia drivers. All it did was screw something up so desktop effects didn't work anymore. It's still using the Nouveau drivers, judging by the fact that it isn't using the NVidia drivers, and by the output of dmesg and lsmod. I don't really understand how it manages to use drivers that I've just removed, but the fact remains that it is managing it :\
    – RobinJ
    Dec 10, 2011 at 22:53
  • Nopes, none of those. The bounty is running to an end, so I'm going to award it to you, even though the problem isn't fixed yet. You're answer was very informative, and I think in a normal case (somehow mine doesn't seem to be normal) it would have worked. So you deserve it :)
    – RobinJ
    Dec 11, 2011 at 17:50

Well, I upgraded to Xubuntu 11.10 and installed the nvidia-173 drivers. My laptop gets slightly hotter than usual (only slightly because I keep my CPU at 1Ghz with cpufrequtils), but at least I haven't experienced any freezes yet. Also, there seem to be no issues with the NVidia drivers for a change (appart from the fact that Plymouth only shows up in the last 2 seconds of the boot process, but at least it does show up this time).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .