0

I would like to set my laptop with UEFI firmware and a Windows 10 / Arch Linux dual boot to use the Linux Boot Manager (managed by systemd-boot) by default on startup, instead of the OS Boot Manager (which boots Windows 10 only). In my own attempts to fix this problem, I pressed Esc on startup and pressed F10 to enter "BIOS Setup". Then I went to the "Boot" tab and found that my options for what device I boot from were:

  • USB (UEFI)
  • USB
  • OS Boot Manager

My default setting at the moment is USB (UEFI), as it makes booting from a live USB more convenient as this is not too uncommon for me to do.

As you can see there is no "Linux Boot Manager" option. I can access the Linux Boot Manager, option by pressing F9 (which gives me my boot options) after pressing Esc on boot, so I know it is there. It works too, I am presently running Arch Linux, which I booted via this method. This question, however, is me asking whether I can get my laptop to automatically boot the Linux Boot Manager instead of the OS Boot Manager, when no live USB is available to boot from.

Per Libre Arch's answer I ran:

efibootmgr -c -d /dev/sda -p 2 -l /EFI/systemd/systemd-bootx64.efi -L "Linux Boot Manager"

after disabling both Safe Mode and Secure Boot in UEFI and this returned:

** Warning ** : Boot0005 has same label Linux Boot Manager
BootCurrent: 0005
Timeout: 2 seconds
BootOrder: 0000,0006,3006,0001,0005,0008,2001,2002,2003
Boot0001* grub
Boot0002* Notebook Hard Drive
Boot0004* Internal Hard Disk or Solid State Disk
Boot0005* Linux Boot Manager
Boot0006* Windows Boot Manager
Boot0007* Internal Hard Disk or Solid State Disk
Boot0008* rEFInd Boot Manager
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk
Boot3006* Internal Hard Disk or Solid State Disk
Boot0000* Linux Boot Manager

yet still whenever I reboot my Windows Boot Manager (i.e., OS Boot Manager) is being used by default. /EFI/systemd/systemd-bootx64.efi does exist on /dev/sda2.

  • Does /EFI/systemd/systemd-bootx64.efi exist? – fpmurphy Mar 23 '16 at 3:17
  • Sure does, I even just edited this question to include that fact. I was going to share its contents until I realized that .efi files are not text files. – BH2017 Mar 23 '16 at 5:27
0

Your probably installed Windows 10 after Arch Linux and Windows wiped out the systemd-boot UEFI entry. You need to re-enable systemd-boot to have the menu you want. Make sure that you have Secure Boot and Fast Startup disabled in the UEFI/BIOS settings and follow the instructions written here on the Arch Wiki.

You might also be able to use the GRUB repair tool to install GRUB (instead of systemd-boot) via a live USB.

  • I tried the suggestions in your first paragraph and they failed, that is, still the Windows OS Boot Manager is being used by default. I went into my BIOS setup menu (by pressing F10), so I can change the boot preferences, and no Linux Boot Manager option appears in this menu, so I can't fix this issue. GRUB is proving too much of a pain for me to be willing to try it again, at least not until this OS Boot Manager issue is fixed. The precise command I ran based on your ArchWiki Link was efibootmgr -c -d /dev/sda -p 2 -l /EFI/systemd/systemd-bootx64.efi -L "Linux Boot Manager" – BH2017 Mar 23 '16 at 2:31
  • @BrentonHorne Did you follow the instructions written under the heading "Menu does not appear after Windows upgrade" in the Arch Wiki link that I mentioned? – Libre Arch Mar 25 '16 at 11:29
  • Nope, didn't seem relevant since I haven't done a Windows 10 update since installing Arch Linux. – BH2017 Mar 25 '16 at 11:31
  • @BrentonHorne Which OS did you install first? Arch or Windows? – Libre Arch Mar 25 '16 at 11:36
  • Windows 8 came pre-installed on this PC, then I upgraded to Windows 10 and then I installed Arch Linux. – BH2017 Mar 25 '16 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.