2

I use vim and I mapped CapsLock to Escape. Recently I decided to switch from qwerty keyboard to Colemak keyboard layout. Colemak maps CapsLock to Backspace. How can I map CapsLock to Escape back? In Linux Mint (what I use) it is possible to change setting to define CapsLock behaviour. It works when I use qwerty, but it breaks when I switch to Colemak.

Also I tried xcape. After installing it, I added the following lines to my .profile:

setxkbmap -option 'caps:ctrl_modifier'
xcape -e 'Caps_Lock=Escape'

However, it does not map CapsLock to Escape back. Any suggestions?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.