1

I have installed GRUB on my Arch Linux installation on /dev/sdb1. /dev/sdb is my second internal hard drive on which I installed Arch Linux, /dev/sda is my first internal hard drive and has Windows 10 installed on it. /dev/sda2 is my EFS partition for UEFI. Then I ran (this I based on the ArchWiki article on GRUB's UEFI subsection)

mount /dev/sda2 /boot
grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub

from within the arch-chroot I generated when I installed Arch Linux on this partition. Then I rebooted and when I got into GRUB from the UEFI boot menu, I had the GRUB minimal interface (i.e., the one that reads "Minimal BASH-like line editing is supported...") only, and I did not know what to do. I have been able to install and boot Arch Linux without a problem on an older PC running BIOS, so I am rather stumped. Here is the output of parted /dev/sda print:

Model: ATA WDC WD10JPVX-60J (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  420MB   419MB   ntfs         Basic data partition          hidden, diag
 2      420MB   693MB   273MB   fat32        EFI system partition          boot, esp
 3      693MB   827MB   134MB                Microsoft reserved partition  msftres
 4      827MB   974GB   974GB   ntfs         Basic data partition          msftdata
 5      974GB   975GB   955MB   ntfs                                       hidden, diag
 6      975GB   1000GB  24.8GB  ntfs         Basic data partition          hidden, msftdata
  • wiki.archlinux.org/index.php/… – jasonwryan Mar 15 '16 at 17:17
  • Attempting to boot from both systemd-boot and rEFInd gives the error message: error: no such device ad4103fa-d940-47ca-8506-301d8071d467. Loading Linux core repo kernel .... error: no such partition. Loading initial ramdisk ... alloc magic is broken at 0x4c3f4540: 4c487920. – BH2017 Mar 15 '16 at 17:57
  • Did you configure the grub after installing it? – Bernardo Meurer Mar 15 '16 at 19:03
  • i.e. ran grub-mkconfig -o /boot/grub/grub.cfg? – Bernardo Meurer Mar 15 '16 at 19:04
1

I found a workaround. I used systemd-boot instead of GRUB2. If you have an actual solution to the problem I will be happy to accept it, as I prefer using GRUB2 over systemd-boot. Until then, however, I will use this workaround. But this was not an automatic fix, I had to work at it. I am sharing it, in case someone in a similar position finds this workaround helpful. What I did was I mounted my /dev/sda2 partition on /boot/efi and copied vmlinuz-linux and initramfs*.img from /boot into /boot/efi. Then I ran the bootctl commands mentioned at the ArchWiki. So in summary, I ran:

mount /dev/sda2 /boot/efi
cp /boot/initramfs*.img /boot/efi
cp /boot/vmlinuz-linux /boot/efi
bootctl --path=/boot/efi install

Then I created the necessary /boot/efi/loader/loader.conf file:

#timeout 3
default arch
timeout 4
editor  0

then I created the following /boot/efi/loader/entries/arch.conf file:

title    Arch Linux
linux    /vmlinuz-linux
initrd   /initramfs-linux.img
options  root=UUID=d26c3e60-0cfb-4118-9dec-1f1819439790 rw

where d26c3e60-0cfb-4118-9dec-1f1819439790 is the UUID (determined by running ls -ld /dev/disk/by-uuid/*) of /dev/sdb1.

-1

Did you generate your fstab? Arch Wiki #fstab

like so

# genfstab -U /mnt >> /mnt/etc/fstab

  • hey now, let's not get rude. – oxenfree Mar 15 '16 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.