I have installed Linux Mint-17 on my laptop. However, i am unable to connect to any wireless network. A red dot is flashed under the network icon on the bottom-right corner(near clock).

I referred the link:- Connecting Linux Mint to WiFi network which suggested to execute:-

sudo apt-get install b43-fwcutter firmware-b43-installer

So, i connected by cellphone through USB-tethering and successfully executed this command. However, the red dot still persists and i am unable to connect to wireless network.

The laptop has a realtek8723BE pci network adapter.

When i execute iwconfig, the output is:-

lo       no wireless extensions.

eth0     no wireless extensions.

How should i connect to wireless network ??

  • 1
    Please open terminal and enter wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info This is a diagnostic tool and it will create a file named wireless-info.txt. Please copy the contents of this file and paste at paste.ubuntu.com and post the URL. Is this a newer HP laptop?
    – Jeremy31
    Mar 16 '16 at 12:01
  • Nope, this is Lenovo laptop. I will try your solution and get back... Mar 17 '16 at 3:54
  • Meanwhile, i have connected Intex wifi dongle to connect to my Access Point and start internet. Mar 17 '16 at 3:55
  • paste.ubuntu.com/15406059 Mar 17 '16 at 4:10

We can try Larry Fingers driver for the rtl8723be

sudo apt-get install git linux-headers-generic build-essential dkms
git clone https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms build rtlwifi-new/0.6
sudo dkms install rtlwifi-new/0.6



You will need to install compilation tools:

sudo apt-get install linux-headers-generic build-essential git 

Next, clone the tree containing the Realtek driver code:

 git clone http://github.com/lwfinger/rtl8723be 

Finally, compile the code:

cd rtl8723be
make clean
sudo make install
sudo modprobe rtl8723be 


Solution 2 : Open the /etc/modprobe.d/rtl8723be.conf file in a text editor, with sudo or root permissions. Then, add the following text:

 options rtl8723be fwlps=N ips=N 

Now, for these changes to take effect, reboot.

  • git clone http://github.com/lwfinger/rtl8723be results in only a readme file in rtl8723be directory
    – Jeremy31
    Mar 25 '16 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.