0

I have been playing around with using Linux Mint on an older Mac Book (2009 era). Linux Mint runs great on this laptop as compared to OS X.

The only major problem I am having is with the trackpad. It is really hard to use. For example if I hold my left pointer finger in the bottom left corner of the trackpad and try and move the mouse with my right pointer finger it will not move until remove my left finger.

The two finger scrolling works, but it is very very fast. The slightest movement puts it to the bottom of the screen.

Does anyone have any suggestions on how to setup the trackpad properly? I have tried xserver.xorg.input.mtrack but it wanted to remove a ton of xserver applications. I tried it anyways and xserver would not start back up on reboot, had to reinstall.

1

First, check that the universe repository is enabled by inspecting /etc/apt/sources.list with your favourite editor.

You will need to use sudo to ensure that you have permissions to edit the file.

sudo gedit /etc/apt/sources.list

If universe is not included then modify the file so that it does.

deb http://us.archive.ubuntu.com/ubuntu vivid main universe

After any changes you should run this command to update your system.

sudo apt-get update

To install, type the following command:

sudo apt-get install xserver-xorg-input-mtrack

To get more information, see xf86-input-mtrack

  • That is what I tried before. When installing xerver-xorg-input-mtrack I have to install the dependency xserver-xorg-core. When installing that it tries to remove tons of packages, mostly xserver-xorg-video... or xserver-xorg-input... When I tried it last time it broke my GUI after a reboot. – tyelford Mar 15 '16 at 10:34
  • Try to install libmtdev1 , libc6 , xorg-input-abi-21 and xserver-xorg-core – GAD3R Mar 15 '16 at 10:46
  • Good new: After installing that and mtrack my trackpad was perfect. Bad news: like I said in my post after reboot Xserver does not load with the following error -- MDM: Xserver not found: /usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.Xau – tyelford Mar 15 '16 at 11:06
  • sudo apt-get install --reinstall xserver-xorg – GAD3R Mar 15 '16 at 16:45
  • Thanks for that. I feel like I am going around in circles. Is there a way to active mtrack on startup now. After reinstalling xserver-xorg I have lost the nice trackpad functionality. – tyelford Mar 15 '16 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.