I have various video files as MKV, including some high-def (1080p) with FLAC audio. These can be played fine on a several-years-old PC with a mid-range graphics card (using mpv/ffmpeg), but when I tried to play them on a Kindle Fire HD8 (using VLC for Android) it caused it to choke.

How can I reencode them such that the lower-powered machine can play them? I assume this will lead to a decline in quality, but I doubt I would notice on the smaller screen anyway. I already have ffmpeg installed and hope to just use that, but if it's easier I can install some other tool. Presumably there are multiple tradeoffs to be made here; it would be nice to have some idea of the options. (I can also post more details about the precise encoding of the files in question, if that would be useful; at the moment I don't know what would be relevant.)


2 Answers 2


I'm not sure about the Kindle, but I have used something like this to convert videos to play on my tiny Nano screen. It might work on your Kindle.

PARAMS="-b 40k -s 640x480 -aspect 640:480"
ffmpeg -i infile.mkv -vcodec copy $PARAMS -acodec copy outfile.mkv

Adjust the size parameter and the aspect ratio for your Kindle. Also, the bit rate parameter of 40k may be too low. Try 50k or 64k.

If you want to convert from FLAC to MP3, you can use something like

APARAMS="libmp3lame -ac 2 -ar 4800 -ab 192k"
ffmpeg -i infile.mkv -vcodec copy $PARAMS -acodec $APARAMS outfile.mkv

Just in case you want to change from MKV to WMV, or something else, try this

ffmpeg -i infile.mkv -vcodec wmv2 $PARAMS -acodec copy outfile.wmv
I suspect VLC will play the MKV. I just thought I'd mention how to change that in case you wanted to see what effect it has.


I ended up doing something like:

ffmpeg -i input-file.mkv -vcodec h264 -s:v 1280x800 -acodec copy output-file.mkv

Of note: using -vcodec copy doesn't work, since that bypasses the decode/encode altogether and thus doesn't allow applying filters. Downscaling the video to this degree ended up shrinking the files dramatically and solving the problems with performance. I also tried further restricting the bitrate with -b, but that caused a noticeable quality hit while not making any difference to playback performance.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .