1

I'm running Debian on my desktop, laptop, and netbook. On my desktop and laptop, I am using Gnome desktop environment; whereas my netbook is using i3wm (installed after a text-only install initially). In all cases, I am using the base16 colour sets in the same way (sourced from .bashrc). In both cases, the underlying TERM variable is xterm-256color. The netbook uses xdm while the others use gdm.

On my desktop and laptop, my highlighting works correctly, as seen here: Desktop Highlighting

Note how the bar at the bottom of man reverses the colour of the text; and selecting the line in the terminal reverses the colour of the text also.

However, on the netbook, this is what I am getting: Netbook Highlighting

Note how the highlighting is always white, regardless of what is underneath.

I have no idea why this is. I did something the other day which temporarily fixed it, but I do not remember what I did, nor if I undid it; and it is currently displaying as in the image.

Can anybody tell me how I can fix this? Where would the setting be for this highlighting?

3

Selection probably means with the mouse (or touchpad). In xterm, there are resource settings related to that:

highlightColor
Specifies the color to use for the background of selected (highlighted) text. If not specified (i.e., matching the default foreground), reverse video is used.

highlightColorMode
Specifies whether xterm should use highlightTextColor and highlightColor to override the reversed foreground/background colors in a selection.

highlightReverse
Specifies whether xterm should reverse the selection foreground and background colors when selecting text with reverse-video attribute.

highlightTextColor
Specifies the color to use for the foreground of selected (highlighted) text. If not specified (i.e., matching the default background), reverse video is used.

Perhaps you used something with xrdb to modify the settings. Putting them in a resource file works well enough.

1
  • Thank You. I don't remember changing any of these values, but setting highlightReverse to on has fixed my problem. – DiJuMx Mar 15 '16 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.