0

I was having the issue of a black screen on Ubuntu restart and startup. It seems like my monitor is somehow disconnected when I start Ubuntu because I get 'No Signal Detected'.

I started following this guide on how to fix it but whenever I change anything in the Grub Boot Menu like nomodeset then press Ctrl + X or F10 to boot, it just goes to this screen:

Frozen Grub Boot Menu

Then stays like this. Doesn't respond to any keys.

The only way to boot is to turn off the computer when the monitor turns off then turn the computer back on, getting to the following screen and selecting 'Ubuntu'.

countdown.

I even tried reinstalling and have the same issue.

Can anyone help?

7
  • did you try a sudo update-grub in a terminal? maybe your grub.cfg file is corrupted or sth
    – joH1
    Mar 14, 2016 at 16:46
  • @Moonstroke Just tried that, no luck. Mar 14, 2016 at 18:28
  • how old is your hard disk? You say that rebooting sometimes works, so my first guess is that your disk is dying (or the data or power cable is loose), which is sometimes preventing grub from loading its boot menu. Otherwise, my second guess is that it could be faulty RAM or some other hardware fault - can you boot reliably on a USB stick or CD-ROM?
    – cas
    Mar 15, 2016 at 2:15
  • @cas It's not old, it's a Crucial M4 SSD. Yes I can reliably boot from USB. Rebooting only works when forcing turning off then on again, added details to post. Mar 15, 2016 at 8:33
  • Look very carefully at your hard disk activity light when you boot. Is it flickering after you see the black screen appear? With SSDs the load time is so short that it's harder to use this method to test what's going on, but it may still give you some idea. Also check your partition filled percentage, make sure home / root are not full, just as one more test to confirm. Use df -hT. Your issue rings a faint bell but I can't remember what the cause was.
    – Lizardx
    Mar 22, 2016 at 3:46

2 Answers 2

1

Removing 'quiet splash' from the boot options allowed me to restart and boot, although now I'm just seeing text when entering my encryption password, not the nice Ubuntu Mate screen. I removed it from /etc/default/grub then did sudo update-grub too. Not ideal but it works.

4
  • In the future when you post an issue for help, please do not leave out the critical information that would point people to the solution, in your case, Mate desktop plus Encryption. These are both relatively non standard for a user desktop, and would have saved you some debugging time. Particularly encryption plus mate. Those two together introduce a solid set of possible failure points. As an alternate test, I'd also recommend trying a different desktop and display manager and see if the issue is in mate, the encryption password step, or both together.
    – Lizardx
    Mar 22, 2016 at 19:51
  • @Lizardx I included Mate as a tag but yeah, I should have included the encryption too. Not going to reinstall my OS again just to try to find the issue though, as that's what I'd need to do to replicate it. Mar 22, 2016 at 20:40
  • I mentioned this combination in particular because there's a much higher level of complexity with two relatively uncommon things running together: mate + encryption login. The pool of possible people to catch bugs in that scenario grows quite small, and your personal odds of finding one grow correspondingly large. In general reinstalls are a poor solution since you don't really learn why the issue is happening. I would guess that mate is failing to talk to the relevant encryption tool and nobody has yet noticed this fact, or fixed it. Could be mdm itself. Small projects have finite manhours.
    – Lizardx
    Mar 22, 2016 at 21:49
  • Thanks for the advice. I understand reinstalls are a poor solution which is why I made the thread and persevered with the OS since I like Ubuntu Mate. I'm pretty much out of ideas of what to try now though if I want to get the Ubuntu Mate encryption screen back, not something I'm desperate for but due to the lack of replies, seems like not many people have had this issue. Mar 22, 2016 at 22:33
0

Have you done an fsck? I know that seems crazy but it's really not out of the ordinary for an SSD to fail even fresh out of the box.

1
  • How do I run this and on which partition? Mar 22, 2016 at 18:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .