This question already has an answer here:

I need Java 1.4.2 on a up-to-date Amazon Linux 2015.09 server. I've tried to install j2sdk-1_4_2_19-linux-ia64-rpm.bin. When I execute this file, I get an error message:

line 442: ./install.sfx.12314: cannot execute binary file

Maybe I'm doing this the wrong way. I downloaded the binary from Oracle, where I see that the most recent Linux (non Solaris) version is Java SE Development Kit 1.4.2_19:


  • Java SE Development Kit 1.4.2_19 31.69 MB j2sdk-1_4_2_19-linux-ia64-rpm.bin
  • Java SE Development Kit 1.4.2_19 32.64 MB j2sdk-1_4_2_19-linux-ia64.bin

Uname -a shows this:

Linux 4.1.17-22.30.amzn1.x86_64 #1 SMP Fri Feb 5 23:44:22 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I've tried both bin files, and both report the same error.

How can I install Java 1.4.2 on this machine?

marked as duplicate by Stephen Kitt, garethTheRed, Rui F Ribeiro, Anthon, Jakuje Mar 14 '16 at 20:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • "Public support and security updates for Java 1.4 ended in October 2008. Paid security updates for Oracle customers ended in February 2013." Also, it's probably 32-bit, and that looks like a 64-bit machine. – thrig Mar 14 '16 at 16:34
  • This bin j2sdk-1_4_2_19-linux-ia64.bin looks 64 bit! I don't care about security updates. This will only be used to run one script. The default Java 1.7 install will stay next to it. – SPRBRN Mar 14 '16 at 16:41

The ia64 files are for Itanium systems; your Amazon Linux server can't run them. You need to download the i586 versions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.