0

I am trying to make two node clusters with pacemaker and corosync. When I want to change config with crm I get the following error:

CIB not supported: validator 'pacemaker-2.0', release '3.0.9'

I can use crm for status and other feature but I can't change config with it. Does anyone work with pacemaker?

I use Ubuntu 15.10

1
  • I am not sure what the etiquette is for posting on multiple stacks, but I answered this same question over on serverfault earlier today. I don't have as many points over here though :-P Mar 14, 2016 at 22:23

1 Answer 1

0

If you look at the first line/tag in your Pacemaker configuration (# cibadmin --query > /tmp/cib.xml) you should see something like the following:

<cib validate-with="pacemaker-2.0" crm_feature_set="3.0.9" ... >

This tells Pacemaker how to validate configurations in environments that might have mixed versions.

Without seeing the configuration you're trying to push, or knowing more about your environment, I'm not certain what the correct setting for "validate-with" would be. However, running the following command might be what you want to bring it up to something more recent:

# cibadmin --modify --xml-text '<cib validate-with="pacemaker-2.1"/>'

If you're trying with some older configuration, maybe you want this instead:

# cibadmin --modify --xml-text '<cib validate-with="pacemaker-1.0"/>'

Either way, I think this is the setting you'll want to tweak.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.