1

I have an X201 tablet with stylus and finger multitouch running Ubuntu 14.04.4 with the 4.2.0 kernel. For no apparent reason, it seems to have an affinity for not recognizing finger (henceforth referred to as "touch") input after previously working. A typical scenario is a seamless boot into a completely functioning tablet, with both touch and stylus completely functional. After some usage, the length of time for which is entirely different each time, an attempt to use the touch function results in disappointment. However, after suspending and waking, functionality returns (although initially suspend would result in the complete loss of functionality of the tablet, but this was remedied after applying this workaround).

Things I've tried:

  1. xsetwacom list devices successfully shows all of my devices, even if they are non-functional at the moment. Here is the output of xsetwacom list devices:

    Wacom Serial Penabled 2FG Touchscreen stylus    id: 13  type: STYLUS    
    Wacom Serial Penabled 2FG Touchscreen eraser    id: 14  type: ERASER    
    Wacom Serial Penabled 2FG Touchscreen touch     id: 15  type: TOUCH
    
  2. sudo inputattach --daemon --w8001 /dev/ttyS*, where * is from dmesg and the command is called after killall inputattach.

  3. lsmod shows both wacom and wacom_8001w.

I've ruled out the possibility of an issue with a connection to an input-layer device. So the serial data is going through (even if it is erroneous). The driver is also loaded.

What is going on? And why does it get fixed by a suspend cycle? And why does it not follow any discernible pattern?


As an aside, sometimes, after waking from suspend and logging in, touch and stylus will work for about 5 seconds, and then completely stop functioning. The same 3 points enumerated above have been tried in this scenario as well with the same results.

0

Try to downgrade the kernel from 4.2.0 to e.g 3.19.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.