2

I am trying to set up Powerline in my xterm. Im running ArchLinux.
I have followed the steps from here and I am at this point here:
enter image description here
So basicaly it works but I just cannot make the arrows appear. This has something to do with the fonts, but I have installed PowerlineSymbols as described in the link above. How can I make the symbols display correctly in xterm?

  • 1
    I guess it's about correct utf8 handling. This can give you a clue: unix.stackexchange.com/questions/116404/… – Tagwint Mar 13 '16 at 10:06
  • Does it work in other terminal emulators? – Sparhawk Mar 13 '16 at 10:29
  • No it does not work... – Cristian Mar 14 '16 at 12:45
  • 1
    I have the very same issue with zsh inside an uxterm, but it works fine in libvte-based terminals. So correct utf8 handling might be required but is not sufficient. – Axel Beckert Jun 3 '16 at 22:12
4

I struggled with this also for a while. What help with me was installing this:

https://github.com/powerline/fonts

And adding the line

XTerm*faceName: DejaVu Sans Mono for Powerline 

into ~/.Xresources.

After that:

xrdb ~/.Xresources

And then reopening xterm.

2

I answered this in Unable to configure font in XTerm; the place to start is to use the -fa option (TrueType fonts) rather than -fn (bitmap fonts).

If you are having trouble getting the font to display, the xfd program is useful, since it accepts an -fa option (like xterm). fontconfig will silently replace your font with something that "works" if it is unable to load the font you requested.

With xfd:

xfd -fa "Powerline Symbols:size=10:antialias=false"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.