0

Hello all i can't open the terminal emulator, when i try to do it, i can see the lines on the picture and then gets closed.

i tried to create a new user but is giving, it worked but i can't compile correctly. so i think is no the final solution.

enter image description here

0

When you open a terminal emulator, your shell is executed. (What is the exact difference between a 'terminal', a 'shell', a 'tty' and a 'console'? might help.) Most Linux distributions have bash as their default shell; other popular choices include zsh, fish, tcsh, ksh, etc.

When your shell starts, it runs an initialization file. Normally bash loads .bashrc, zsh loads .zshrc, fish loads .config/fish/config.fish, etc. Most errors cause the shell to simply stop loading the initialization file and display a command prompt, but a few problems can cause the shell to exit. So check your initialization file and correct the problems. If you aren't sure what is good and what isn't, move your initialization file to another name, then create a new file and copy the content little by little, testing it each time.

Your initialization file is the most likely culprit, but it could also be a system-wide file (e.g. /etc/bash.bashrc, /etc/zshrc, …).

There are clearly errors related to Code-Aster in your screenshot, but they don't look like they should be fatal. Still, it's hard to tell without seeing the code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.