1

I've tried disabling MPD (Music Player Daemon) using Systemd:

sudo systemctl disable mpd

sudo systemctl status mpd
mpd.service - Music Player Daemon
Loaded: loaded (/lib/systemd/system/mpd.service; disabled; vendor preset: disabled)
Active: inactive (dead)

But MPD runs at every boot regardless.

ps aux | grep mpd

user   1691  0.1  0.8 995424 33108 ?        Ssl  09:07   0:00 mpd
user   2154  0.0  0.0  14216  2464 pts/5    S+   09:17   0:00 grep --color=auto mpd

How can I disable MPD from running at boot?

| improve this question | | | | |
  • MPD is running as your user - does is get started from a user session by any chance (systemctl --user status mpd)? – Wieland Mar 12 '16 at 11:02
  • @Wieland I suspected this too earlier. But systemctl --user status mpd produces Loaded: not-found (Reason: No such file or directory) Active: inactive (dead) – Rocket Singh Mar 12 '16 at 12:10
2

If you run dpkg -L mpd to see what files got installed by the package you should find amongst others

/usr/lib/systemd/system/mpd.service
/usr/lib/systemd/system/mpd.socket

This means that systemd has been configured by mpd to create a socket that then launches the service whenever it is opened. When you disable mpd this is a shorthand for disabling mpd.service. You need to also disable the socket explicitly with

sudo systemctl disable mpd.socket

Update: it appears to be unrelated to systemd. Depending on your window manager, you may have a file in your own directory ~/.config/autostart/ that starts mpd, or try finding a configuration by going through your menus in the approximate order: System -> Preferences -> Sessions -> Startup Programs.

Finally, it appeared in gnome-session-properties as something to disable.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.