1

This is essentially the same as the Ask Ubuntu question How to use JACK and Pulseaudio/ALSA at the same time on the same audio device?.

However, the answers to that question are all incomplete in at least one important respect. They don't specify how to set things up so that Pulseaudio will run on top on Jackd on bootup. They also seem to assume that QjackCtl (a GUI) is used for JACK configuration. This is not appealing.

I was recently able to reconfigure PulseAudio so that it ran on top of JACK. This was very simple. I followed the instructions in this Fedora tutorial.

I just edited the file /etc/pulse/default.pa to add the following lines after the line #load-module module-pipe-sink:

load-module module-jack-sink
load-module module-jack-source

Then I killed PA, as recommended by the Fedora tutorial. PA then started again, but this time on top of JACK.

However, when I rebooted recently, neither JACK or PA started.

So I'd like a more complete solution which works on reboot. I also want a solution that is solely based on modifying config files, not using a GUI. An explanation for how and why the proposed configuration works would also be much appreciated.

I'm using Debian Jessie (8.3). However, I'd like answers that apply as broadly as possible, for maximum usefulness. Clean approaches which don't use the approach of the Fedora tutorial are also fine, of course.

It's also worth noting that the JACKD project itself has configuration recommendations, in Running PulseAudio on top of JACK and How use PulseAudio and JACK?. But I'm not sure what it is telling me to do.

0

As you are running JACK and Pulseaudio from boot, try delaying the JACK command for a few seconds so that Pulseaudio and other sound elements are up and running first

If available, using package jack2-dbus instead of jackd or jack2 would be simplest solution. D-Bus controls sharing of audio hardware between JACK and Pulseaudio. if Pulseaudio module module-jackdbus-detect is active in /etc/pulse/default.pa JACK will automatically create the Pulseaudio sink and source when started.

If you can't use D-Bus for some reason comment out this section in /etc/pulse/default.pa with a '#' at beginning of each line

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

this will disable Pulseaudio from claiming use of any audio hardware device that may be needed for JACK to start properly. Then you can start JACK with a bash script including commands to load the Pulseaudio sink and source:

#!/bin/bash
<jack start command>
wait 2
pactl load-module module-jack-sink
pactl load-module module-jack-source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.