3

I can't seem to get LibreOffice to consistently number my headings.

I created a new document on one computer, with my headings set up to number thusly:

1  First Heading 1 
1.1  Heading 2
2  Second Heading 1-
2.1  Heading 2
2.1.1  Heading 3

Originally, I could assign the appropriate heading to any text and the format and numbering would continue. eg

2.1.2  Heading 3-2

Now that I've moved to my laptop, the same document no longer auto outlines headings. Even if I manually click the numbering button and change the numbering format to outline, the numbering doesn't continue from where it left off. If I subsequently change the heading level, eg from 3 to 2, or 2 to 3, the same numbering is kept, i.e. no indenting of the number. So now my document looks like something like this

1  Orginal Heading 1 
1.1  Orginal Heading 2
2  Orginal Second Heading 1
2.1  Orginal Heading 2
2.1.1  Orginal Heading 3
1 New Heading 1
  2 New Heading 2
    3 New Heading 2

Can't Libreoffice maintain a consistent numbering strategy across headings?

5
  • 1
    Perhaps this question is better for official LibreOffice support channels, as it's not really specific to Unix/Linux.
    – jayhendren
    Mar 11, 2016 at 19:31
  • 1
    @jayhendren Questions about cross-platforms applications are fine. We have questions about Firefox (there are versions that run on Windows), about Bash (there are versions that run on Windows), ... I'm sure we have more bash expertise than LibreOffice expertise on this site, but the question is perfectly appropriate here. Mar 11, 2016 at 23:58
  • 1
    I figured since there was a preexisting tag it was okay. Both systems in question are Linux and I don't have a windows install to test this issue against. I knew stack overflow wouldn't be appropriate since it wasn't programming related.
    – gnac
    Mar 12, 2016 at 0:02
  • Ok, thanks for the clarification, @Gilles.
    – jayhendren
    Mar 12, 2016 at 1:01
  • Lucky you, I'm still struggling with Chapter2, New Header 1.1 problem.
    – Owl
    Oct 18, 2018 at 9:30

1 Answer 1

2

It sounds like the document may have mixed numbered lists and outline numbering. I recommend only using style-based numbering. Set up the numbering by going to Tools -> Outline Numbering and clicking 1 - 10.

if I manually click the numbering button...

Try to avoid doing this in the future. This adds a text:is-list-header tag which is unfortunately invisible. It does not surprise me that the result is several different numbering schemes and formats. The tag can also be added by clicking on a heading in front of the number and pressing backspace -- try to avoid doing this too.

The problem can be fixed after playing around with the headings for a little while. See https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=4770.

The problem is tricky because the tags are not displayed. The tags can be viewed in content.xml by unzipping the .odt file. Actually it may be easier just to fix the problem by editing content.xml.

2
  • I didn't want to have to click the numbering button, I only reverted to using that when my auto-header numbering stopped working. i.e. on the first computer, setting a text to a header format would automatically and correctly set the outline numbering. It was only when opening the file on a different computer that I ran into the issue and started dorking around with the numbering button and other ways to "fix" the numbering. I'll read the thread you posted and if necessary manually edit content.xml. I'll let you know what comes up. Thanks.
    – gnac
    Mar 15, 2016 at 20:46
  • Tools -> Chapter Numbering seems to be the current name for the dialog box to control numbering the headings.
    – pds
    Sep 23, 2022 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .