1

I run Debian 8 Jessie on my Sony Vaio Laptop. It has an Nvidia Geforce GT 640M LE graphics chip.

I followed the official Debian Wiki article to install nvidia-drivers instead of nouveau:

https://wiki.debian.org/NvidiaGraphicsDrivers

Now I am running Nvidia Driver 352.79 which should be compatible to my GPU according to the mentioned wiki pages. After the installation I ran nvidia-xconfig which created an /etc/X11/xorg.conf for me automatically:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

The problem is when I boot up, I do not get to see the desktop environment - here is the complete Xorg.0.log:

[    21.803]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[    21.803] X Protocol Version 11, Revision 0
[    21.803] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[    21.803] Current Operating System: Linux sony-jessie 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u4 (2016-02-29) x86_64
[    21.803] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=743ceb34-b848-49b3-8a7e-b5c86d2abf7c ro quiet
[    21.803] Build Date: 11 February 2015  12:32:02AM
[    21.803] xorg-server 2:1.16.4-1 (http://www.debian.org/support)
[    21.803] Current version of pixman: 0.32.6
[    21.803]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    21.803] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    21.804] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 11 19:08:24 2016
[    21.804] (==) Using config file: "/etc/X11/xorg.conf"
[    21.804] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    21.804] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    21.804] (==) ServerLayout "Layout0"
[    21.804] (**) |-->Screen "Screen0" (0)
[    21.804] (**) |   |-->Monitor "Monitor0"
[    21.805] (**) |   |-->Device "Device0"
[    21.805] (**) |-->Input Device "Keyboard0"
[    21.805] (**) |-->Input Device "Mouse0"
[    21.805] (==) Automatically adding devices
[    21.805] (==) Automatically enabling devices
[    21.805] (==) Automatically adding GPU devices
[    21.805] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    21.805]    Entry deleted from font path.
[    21.805] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        built-ins
[    21.805] (==) ModulePath set to "/usr/lib/xorg/modules"
[    21.805] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    21.805] (WW) Disabling Keyboard0
[    21.805] (WW) Disabling Mouse0
[    21.805] (II) Loader magic: 0x7f0af2e3cd80
[    21.805] (II) Module ABI versions:
[    21.805]    X.Org ANSI C Emulation: 0.4
[    21.805]    X.Org Video Driver: 18.0
[    21.805]    X.Org XInput driver : 21.0
[    21.805]    X.Org Server Extension : 8.0
[    21.806] (II) xfree86: Adding drm device (/dev/dri/card0)
[    21.806] (II) xfree86: Adding drm device (/dev/dri/card1)
[    21.808] (--) PCI:*(0:0:2:0) 8086:0166:104d:909c rev 9, Mem @ 0xb9000000/4194304, 0xc0000000/268435456, I/O @ 0x00007000/64
[    21.808] (--) PCI: (0:1:0:0) 10de:0fd3:104d:909c rev 161, Mem @ 0xb8000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00006000/128
[    21.809] (II) LoadModule: "glx"
[    21.809] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    21.821] (II) Module glx: vendor="NVIDIA Corporation"
[    21.821]    compiled for 4.0.2, module version = 1.0.0
[    21.821]    Module class: X.Org Server Extension
[    21.821] (II) NVIDIA GLX Module  352.79  Wed Jan 13 15:54:44 PST 2016
[    21.821] (II) LoadModule: "nvidia"
[    21.821] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    21.822] (II) Module nvidia: vendor="NVIDIA Corporation"
[    21.822]    compiled for 4.0.2, module version = 1.0.0
[    21.822]    Module class: X.Org Video Driver
[    21.822] (II) NVIDIA dlloader X Driver  352.79  Wed Jan 13 15:31:15 PST 2016
[    21.822] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    21.822] (++) using VT number 7

[    21.822] (EE) No devices detected.
[    21.822] (EE)
Fatal server error:
[    21.822] (EE) no screens found(EE)
[    21.822] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    21.822] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    21.822] (EE)

Especially the following lines should be of use. Unfortunately not for me, I could not find anything useful about it:

[    21.822] (EE) No devices detected.
[    21.822] (EE)
Fatal server error:
[    21.822] (EE) no screens found(EE)

1 Answer 1

0

Forget about the nvidia-driver

All you need for a GeForce card is Bumblebee.

See allicoder's answer as well as mine on the subject.

Also be sure to checkout the Bumblebee FAQ.

3
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review
    – grochmal
    Aug 25, 2016 at 3:05
  • @grochmal: I'm actually not so sure, although the answer is of doubtful quality. Aug 25, 2016 at 4:03
  • I'm sorry I just stumbled upon this question after I had already answered the other one and got lazy. I am aware that I need reputation to comment, and I tried my best to provide an actual answer but the problem is nobody seems to have gotten the nvidia-driver to work in such a setup, and bumblebee does provide a way to use the graphics card, which is - I assume - the intent of the writer. Aug 27, 2016 at 9:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .