My current openssl version is openSSL 0.9.8e-fips-rhel5. I want to upgrade this to openssl-1.0.1s. The yum update openssl will not work here.

I removed openssl binaries from following path

/usr/lib/openssl and /usr/bin/openssl

And tried to compile it from source.

./config --prefix=/usr/lib/openssl but it throw following error.

*make[1]: Leaving directory `/root/openssl-1.0.1s/test'
Configured for linux-x86_64.
*** Because of configuration changes, you MUST do the following before
*** building:
        make depend
[root@test openssl-1.0.1s]# make depend
making depend in crypto...
make[1]: Entering directory `/root/openssl-1.0.1s/crypto'
../util/domd: line 25: gcc: command not found
make[1]: *** [local_depend] Error 1
make[1]: Leaving directory `/root/openssl-1.0.1s/crypto'
make: *** [depend] Error 1
[root@test openssl-1.0.1s]# make
making all in crypto...
make[1]: Entering directory `/root/openssl-1.0.1s/crypto'
make[1]: gcc: Command not found
make[1]: *** [cryptlib.o] Error 127
make[1]: Leaving directory `/root/openssl-1.0.1s/crypto'
make: *** [build_crypto] Error 1*

I want to upgrade this because of recently reported openssl vulnerability (Drawn attack). Please help me on this.


Fixed error. Fixed by installing gcc.

  • looks like OP answer his own question, yet I agree a little more content would do no harm. – Archemar Mar 11 '16 at 13:47

It's pretty clear from this message what needs to be done:

../util/domd: line 25: gcc: command not found

You need to install the gcc compiler.

$ sudo yum install gcc
  • I had same issue. Thanks, this fixed it yum install gcc – Binyamin Oct 29 '17 at 19:48

This/my answer does not explain how to update to specific version openssl-1.0.1s but it provides a different and more easy way to update OpenSSL of RHEL 5 to the one of RHEL 6 (which is still supported, UPDATE: RHEL 6 is out of support since November 2020):

  1. Install tuxad repo for RHEL 5: rpm -i http://www.tuxad.de/repo/5/tuxad.rpm
  2. Update packages: yum update

More details can be found here:

www.tuxad.de/blog/archives/2014/11/19/openssl_updatesenhancements_for_rhel__centos_5 www.tuxad.de/blog/archives/2018/07/21/tuxad_rh5_repo_now_with_phpopenssl1

This repo contains several packages which are rebuild against OpenSSL 1:

  • httpd (also include other enhancements like ECDH support)
  • postfix
  • dovecot
  • curl
  • lynx
  • mutt
  • vsftpd
  • w3m
  • wget
  • php
  • php from RHEL 6 backported (in separate repo "tuxad-php")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.