3

I am currently trying to install Debian on a laptop and due to firmware incompatibility, I am using the non-free netinstaller which can be found here. I cp'd it onto a USB (not a partition) and booted which solved the required firmware issue, However, to complete the install I need to connect to the internet. Unfortunately, the Debian installer has no option to connect to a network that uses EAP-PEAP MSCHAPv2 (username/password), common to universities, which is stopping me from completing the install.

From research that I have done so far, I believe that I need to set up the wpa_supplicant manually from command line (ctrl+alt+f2 from the GUI installer). I have tried using a template from the manpages for my settings, but could not get it to work. This is my first experience with wpa_supplicant and I do not have direct access to ethernet, so if anybody could tell me how to connect to the network, it would be much appreciated. If any more information would help to solve the issue, I am willing to provide.

I have been following the Debian Jessie installation guide for amd64 through the install.

2

I ended up solving this problem by not connecting to the internet connection directly, but through connecting to my other machine which is already connected to wifi, thus eliminating the need to enter a username/password on the client. I did this by following the steps here, except for Linux Mint 17.3 KDE.

To do so, I used these basic steps:

  1. Connect the client (computer installing Debian) to the server (Computer already connected to wifi) via an ethernet cable
  2. In the KDE nm applet on the server, select "Auto Ethernet" under the list of available connections. It should appear as an option once the cable is properly connected.
  3. Under "Edit Connections", edit the "Auto Ethernet" connection.
  4. Under the "IPv4 Settinigs" tab, change the "Method" dropdown box to "Shared to other computers.
  5. The client should now automatically connect to the server when selecting eth0 in the Debian installer. Continue with installation!

Note: If you are using a firewall such as ufw on the server, you may want to temporarily disable it (although I left mine on without issues).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.