0

I am trying this on Intel Galileo Gen 2 which runs Yocto Linux and I am unable to connect to Internet using Ethernet. I have WiFi card but that doesn't connect as well. I have tried following commands and their outputs are as below

ifconfig -a

Output:

enp0s20f6 Link encap:Ethernet  HWaddr 98:4F:EE:01:9E:CA
          inet addr:192.168.0.110  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::9a4f:eeff:fe01:9eca/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2731 errors:0 dropped:4 overruns:0 frame:0
          TX packets:599 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:276624 (270.1 KiB)  TX bytes:84524 (82.5 KiB)
          Interrupt:51 Base address:0x4000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:5730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5730 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:503288 (491.4 KiB)  TX bytes:503288 (491.4 KiB)

wlp1s0    Link encap:Ethernet  HWaddr 44:85:00:01:8A:D3
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

route -n

Output:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 enp0s20f6
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 enp0s20f6
192.168.0.1     0.0.0.0         255.255.255.255 UH    0      0        0 enp0s20f6

The interfaces look like:

vi /etc/network/interfaces

auto enp0s20f6
iface enp0s20f6 inet static
  address 10.254.253.1
  netmask 255.255.255.0

auto wlan0
iface wlan0 inet dhcp
     wireless_mode managed
     wireless_essid any
     wpa-driver wext
     wpa-conf /etc/wpa_supplicant.conf

auto lo
iface lo inet loopback

On trying connmanctl services I get,

*AR Wired                ethernet_984fee019eca_cable
*A  wifinw           wifi_448500018ad3_646c696e6b2d32333238_managed_psk

So ping www.google.com fails with bad address. I tried ping 8.8.8.8 and it gives response. As per @frarugi87 its a DNS issue, but I am not sure how to fix this.

The /etc/resolv.conf has following nameservers

# Generated by Connection Manager
nameserver 127.0.0.1
nameserver ::1
1

Resolved this adding OpenDNS servers to my /etc/resolv.conf file.

vi /etc/resolv.conf

and the file looks like

nameserver 208.67.222.222
nameserver 208.67.220.220

After this, ping to google.com works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.