5

From what I understand markdown is pretty similar to text and html, which are all indexed by the recoll search engine.

However my markdown files with extension .md are not being indexed. I have checked the filters and I am not sure which one applies to markdown, or if its support is missing altogether.

If there is a simple way of manually creating a filter then it would be wonderful if someone could help me with creating one. Or if it is a simple setting I'm missing could you please point it out?

I am running the latest version of recoll (1.21.5) on Debian Testing

1 Answer 1

8

Edit ~/.recoll/mimemap, add the following line:

.md = text/plain

This will tell recoll to index markdown as normal text, which it is, mostly, so I think that things should "just work"

1
  • 1
    Thanks! I added .md = text/html .mmd = text/html to the ~/.recoll/mimemap file and it works now. The config file examples located at /usr/share/recoll/examples are also very useful Commented Mar 15, 2016 at 13:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .